FIX: Non È possibile sospendere o terminare le istanze di orchestrazione servizio dopo l'arresto in modo errato un'istanza di host BizTalk Server in Microsoft BizTalk Server 2006 R2

Traduzione articoli Traduzione articoli
Identificativo articolo: 969987 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di sospendere o interrompere alcune istanze di orchestrazione servizio in BizTalk Server Administration Console di Microsoft BizTalk Server 2006 R2, le istanze di orchestrazione servizio rimangono in stato attivo. Di conseguenza, queste istanze di orchestrazione servizio visualizzato non risponde.

Questo problema si verifica in genere dopo alcune istanze di host BizTalk Server vengono arrestate in modo non corretto. Alcuni componenti della pipeline personalizzato che si siano utilizzando, ad esempio, non risponda. Se si riavvia il processo di BizTalk Server (btsntsvc.exe) per il ripristino da questo, è possibile che si verifichi questo problema.

Cause

Questo problema si verifica perché si è verificato un problema in una stored procedure nel database di BizTalkMsgBoxDB.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano questo problema specifico.

Se l'aggiornamento rapido (hotfix) è disponibile per il download, non vi è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua in uso, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Informazioni per l'installazione

Questo aggiornamento rapido (hotfix) consente di aggiornare il database di BizTalkMsgBoxDB. Per evitare errori e gli arresti anomali imprevisti durante l'installazione dell'aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Arrestare il servizio Agente SQL Server che esegue i processi di Agente SQL Server BizTalk.
  2. Arrestare il servizio Internet Information Services (IIS) per interrompere tutte le istanze di host isolate BizTalk.
  3. Interrompere tutte le istanze di host BizTalk nel gruppo BizTalk in cui il problema si verifica in esecuzione.
  4. Applicare questo aggiornamento rapido (hotfix).

Prerequisiti

È necessario disporre di BizTalk Server 2006 R2 per applicare questo aggiornamento rapido (hotfix).

Necessità di riavvio

Dopo aver installato l'aggiornamento rapido (hotfix), riavviare il servizio Agente SQL Server, il servizio IIS e le istanze di host BizTalk.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce un aggiornamento rapido (hotfix) rilasciato in precedenza.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Msgbox_application_logic.SQLNon applicabile529,12803-06-200914: 42Non applicabile
Nota A causa delle dipendenze fra i file, l'aggiornamento rapido più recente contenente questi file può contenere anche file aggiuntivi.

Workaround

Per aggirare questo problema, attenersi alla seguente procedura:
  1. Arrestare tutte le istanze di host BizTalk nella console di amministrazione BizTalk.
  2. Arrestare IIS sui server nel gruppo BizTalk in cui si verifica il problema eseguendo il comando riportato di seguito:
    net stop iisadmin/y
  3. Attendere cinque minuti.
  4. Nella console di amministrazione BizTalk, sospendere o terminare le istanze di orchestrazione servizio problematici.

Note
  • Quando si arresta tutte le istanze di host BizTalk e lasciare che il processo di SQL Server Agent DeadProcess_Cleanup eseguito per un certo periodo di tempo, le istanze di orchestrazione servizio problematica tornare allo stato normale. Di conseguenza, è possibile sospendere o interrompere tali istanze.
  • Per riavviare il servizio IIS, eseguire il comando riportato di seguito:
    net start w3svc

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni su come gestire e risolvere i problemi relativi a database di BizTalk Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
952555Come gestire e risolvere i problemi relativi a database di BizTalk Server
Per ulteriori informazioni su come sospendere, riprendere e terminare le istanze di orchestrazione, visitare il seguente sito MSDN Web:
http://msdn.microsoft.com/en-us/library/dd761762.aspx
Per ulteriori informazioni sugli stati istanza orchestrazione di servizio, visitare il seguente sito Microsoft TechNet Web:
http://technet.microsoft.com/en-us/library/dd746131.aspx
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 969987 - Ultima modifica: mercoledì 8 luglio 2009 - Revisione: 1.2
Le informazioni in questo articolo si applicano a:
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch
Chiavi: 
kbmt kbbtsadmin kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe KB969987 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 969987
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com