FIX: A workflow in an application or service cannot complete when the IEventActivity.Subscribe method throws an exception in the .NET Framework 3.5 Service Pack 1

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Article ID: 970016 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario in the Microsoft .NET Framework 3.5 Service Pack 1:
  • You run an application or a service that hosts the Windows Workflow runtime.
  • The application or the service creates a workflow that contains a Listen activity.
  • While you run the application or the service, a child branch of the Listen activity in the IEventActivity.Subscribe method throws an exception.
In this scenario, the method in the application or in the service cannot complete, and therefore the CPU usage increases. For example, you may experience this problem when you run the Microsoft CRM 4 Asynchronous Service.

CAUSE

This problem occurs because the workflow that is hosted in the application or in the service enters into an infinite loop in the ListenActivity.Cancel method. Therefore, the service cannot exit the Faulting status.

RESOLUTION

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have the .NET Framework 3.5 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix if no .NET Framework instance is being used.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 and Windows XP, x86-based version:
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File nameFile versionFile sizeDateTimePlatform
System.workflow.activities.dll3.0.4203.41071,142,78428-Apr-200923:30x86
System.workflow.runtime.dll3.0.4203.4107540,67228-Apr-200923:30x86

Windows Server 2003 and Windows XP, x64-based version:
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.workflow.activities.dll3.0.4203.41071,060,86428-Apr-200923:00x64
System.workflow.runtime.dll3.0.4203.4107454,65628-Apr-200923:00x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 970016 - Last Review: October 7, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft .NET Framework 3.5 Service Pack 1
Keywords: 
kbexpertiseadvanced kbsurveynew kbqfe KB970016

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