ID do artigo: 970048 - Última revisão: quarta-feira, 17 de junho de 2009 - Revisão: 1.0

Desempenho lento de impressão ao imprimir em uma impressora LPR a partir de um computador baseado no Windows XP

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Em um computador que está executando o Windows XP, você tentar imprimir em uma porta TCP/IP em uma impressora LPR (Line Printer Remote) usando o software de monitor de porta LPR.
  • Você ativar o recurso de contagem de bytes LPR na impressora LPR ou desativar as opções de TCP/IP avançadas na impressora LPR.
Nesse cenário, você enfrentar desempenho lento de impressão.

Se você rastrear o tráfego de rede quando esse problema ocorre, os resultados de rastreamento de rede indicam que para todos os três pacotes que são enviadas do computador para a impressora LPR, há um pacote de "Atrasada ACK" antes da impressora LPR envia uma confirmação de recebimento.

Causa

Esse problema ocorre porque algumas impressoras LPR usam algoritmos atrasada confirmação (ACK) para diminuir a sobrecarga do TCP. Uma confirmação atrasada pode ocorrer se uma impressora que usa esses algoritmos recebe um número ímpar de pacotes de um computador que envia trabalhos de impressão para a impressora. Durante esse atraso, o computador aguarda para enviar dados adicionais para a impressora.

Além disso, o Monitor de porta TCP/IP e o processador de impressão Windows usam um buffer de 4 quilobytes para enviar dados para a impressora. Um tamanho de buffer de 4 kilobytes causa atrasos mais para confirmações. Esses atrasos se acumular ao longo do tempo e eventualmente causar uma redução significativa a velocidade de transferência geral do trabalho de impressão quando os documentos grandes estiverem sendo impressos.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 2 ou Windows XP Service Pack 3 instalado no computador. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389  (http://support.microsoft.com/kb/322389/ ) Como obter o mais recente do Windows XP service pack

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com Service Pack 2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Tcpmon.dll5.1.2600.355545,56815-Abr-200914: 48x 86
Windows XP com Service Pack 3, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Tcpmon.dll5.1.2600.579545,56815-Abr-200914: 35x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 2
  • Service Pack 3 para Windows XP
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbhotfixserver kbqfe KB970048 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 970048  (http://support.microsoft.com/kb/970048/en-us/ )