Шлюз по умолчанию мог быть задан как 0.0.0.0 в системе Windows Vista или более поздней версии, в которой работает служба Apple Bonjour

Переводы статьи Переводы статьи
Код статьи: 970313 - Vizualiza?i produsele pentru care se aplic? acest articol.
Поддержка системы Windows Vista с пакетом обновления 1 (SP1) прекратится 12 июля 2011 г. Чтобы по-прежнему получать обновления для системы безопасности Windows, установите пакет обновления 2 (SP2) для Windows Vista. Дополнительные сведения см. на указанном ниже веб-сайте корпорации Майкрософт. Заканчивается поддержка некоторых версий Windows.
Развернуть все | Свернуть все
Источник: служба технической поддержки Майкрософт

БЫСТРАЯ ПУБЛИКАЦИЯ

В БЫСТРО ПУБЛИКУЮЩИХСЯ СТАТЬЯХ ПРЕДСТАВЛЕНЫ СВЕДЕНИЯ, ПОЛУЧЕННЫЕ НЕПОСРЕДСТВЕННО ОТ СЛУЖБЫ ТЕХНИЧЕСКОЙ ПОДДЕРЖКИ МАЙКРОСОФТ. СВЕДЕНИЯ, СОДЕРЖАЩИЕСЯ В НИХ, ПРЕДОСТАВЛЕНЫ В ОТВЕТ НА СРОЧНЫЕ ЗАПРОСЫ ИЛИ В КАЧЕСТВЕ ПРИЛОЖЕНИЯ К ДРУГИМ СТАТЬЯМ БАЗЫ ЗНАНИЙ.


Если на компьютере работает служба Apple Bonjour, шлюз по умолчанию мог быть задан как 0.0.0.0.

Причина



Эта проблема возникает, так как служба Bonjour добавляет маршрут, чтобы задать шлюз по умолчанию как 0.0.0.0, который она не удаляет.



Чтобы можно было получить этот маршрут, на компьютере с системой Windows Vista или более поздней версией и службой Bonjour должны произойти следующие события:

  • Компьютер не получает адрес по протоколу DHCP до запуска службы Bonjour.

  • При этом условии служба Bonjour добавляет на компьютере маршрут по умолчанию, указывая, что все интернет-узлы "в сети".

  • После этого компьютер может получить адрес по DHCP. Bonjour не удаляет маршрут по умолчанию, оставляя настроенным неправильный шлюз по умолчанию. Этот шлюз подавляет правильную конфигурацию шлюза, полученную от DHCP, и препятствует доступу в Интернет.

Решение



Если для решения проблемы требуется помощь, перейдите к разделу Помощь в решении проблемы. Чтобы устранить проблему самостоятельно, перейдите к разделу Самостоятельное решение проблемы.

Помощь в решении проблемы



Чтобы решить проблему автоматически, нажмите кнопку или ссылку Устранить проблему. Затем в диалоговом окне Загрузка файла нажмите кнопку Выполнить и следуйте инструкциям мастера.


Устранить проблему
Microsoft Fix it 50812


Примечания
  • Мастер может быть доступен только на английском языке. Однако этот мастер автоматического устранения неполадок работает в версиях Windows на любых языках.
  • Решение Fix it можно загрузить на любой компьютер, а затем сохранить на устройстве флэш-памяти или компакт-диске и запустить на нужном компьютере.

Перейдите в раздел "Проблема устранена?".



Самостоятельное решение проблемы

Чтобы решить проблему самостоятельно, удалите маршрут вручную. Для этого выполните указанные ниже действия.



1. Нажмите кнопку Пуск, введите cmd в поле Начать поиск, щелкните правой кнопкой мыши пункт "cmd.exe" в списке Программы и выберите команду Запуск от имени администратора.



При получении запроса на ввод пароля администратора или подтверждения введите пароль или подтвердите действие.





2. В командной строке введите следующую команду и нажмите клавишу ВВОД:



route delete 0.0.0.0



3. Закройте окно командной строки.



Примечание. Это не гарантирует, что служба Bonjour не создаст такой маршрут снова, так как это зависит от последовательности событий, описанной в разделе "Причина". Если это повторится, снова выполните указанные действия, чтобы удалить маршрут.

Проблема устранена?

  • Проверьте, устранена ли проблема. Если да, пропустите дальнейшие инструкции, приведенные в этом разделе. Если нет, обратитесь в службу технической поддержки.
  • Мы ценим ваши замечания. Чтобы оставить отзыв или сообщить о проблемах, связанных с этим решением, добавьте комментарий в блог Помощь в решении проблемы или отправьте нам сообщение по электронной почте.

Дополнительные сведения



Состояние:

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе "Информация в данной статье применима к".

ЗАЯВЛЕНИЕ ОБ ОТКАЗЕ

КОРПОРАЦИЯ МАЙКРОСОФТ И ЕЕ ПОСТАВЩИКИ НЕ ДАЮТ НИКАКИХ ГАРАНТИЙ НАДЕЖНОСТИ, ТОЧНОСТИ И ПРИГОДНОСТИ ДЛЯ КАКИХ-ЛИБО ЦЕЛЕЙ В ОТНОШЕНИИ СВЕДЕНИЙ, СОДЕРЖАЩИХСЯ В ДОКУМЕНТАХ, И ГРАФИЧЕСКИХ ИЗОБРАЖЕНИЙ (ДАЛЕЕ "МАТЕРИАЛЫ"), ОПУБЛИКОВАННЫХ НА ЭТОМ ВЕБ-САЙТЕ КАК ЧАСТЬ ОКАЗАНИЯ УСЛУГ. МАТЕРИАЛЫ МОГУТ СОДЕРЖАТЬ ТЕХНИЧЕСКИЕ НЕТОЧНОСТИ И ОПЕЧАТКИ. ЭТИ СВЕДЕНИЯ ПЕРИОДИЧЕСКИ ПОДВЕРГАЮТСЯ ИЗМЕНЕНИЯМ БЕЗ ПРЕДУПРЕЖДЕНИЙ.

В МАКСИМАЛЬНОЙ СТЕПЕНИ, ДОПУСКАЕМОЙ ДЕЙСТВУЮЩИМ ЗАКОНОДАТЕЛЬСТВОМ, КОРПОРАЦИЯ МАЙКРОСОФТ И ЕЕ ПОСТАВЩИКИ ОТКАЗЫВАЮТСЯ ОТ ПРЕДОСТАВЛЕНИЯ КАКИХ-ЛИБО ПРЯМЫХ, ПОДРАЗУМЕВАЕМЫХ ИЛИ ПРЕДУСМОТРЕННЫХ ЗАКОНОМ ГАРАНТИЙ В ОТНОШЕНИИ СВОИХ МАТЕРИАЛОВ, ВКЛЮЧАЯ БЕЗ ОГРАНИЧЕНИЙ ГАРАНТИИ ПРАВ СОБСТВЕННОСТИ, НЕНАРУШЕНИЯ АВТОРСКИХ ПРАВ, УДОВЛЕТВОРИТЕЛЬНОГО СОСТОЯНИЯ И КАЧЕСТВА, ТОВАРНОЙ ПРИГОДНОСТИ И СООТВЕТСТВИЯ ОПРЕДЕЛЕННЫМ ЦЕЛЯМ.

Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 970313 - Последний отзыв: 27 февраля 2012 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
  • Service Pack 1 для Windows Vista
  • Service Pack 2 для Windows Vista
  • Windows 7 Корпоративная
Ключевые слова: 
kbrapidpub kbnomt kbmsifixme kbfixme KB970313

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com