Article ID: 970772 - Last Review: June 26, 2009 - Revision: 1.1

FIX: IIS Manager does not display the user interface in the language of the remote server when you connect to a remote Internet Information Services (IIS) 7.0 server

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You use IIS Manager to manage a remote server that is running Internet Information Services (IIS) 7.0.
  • The language of the computer on which you are running IIS Manager differs from the language of the remote IIS 7.0 server.
In this scenario, when you connect to the IIS 7.0 server in IIS Manager, the user interface is not displayed in the language of the remote IIS 7.0 server. Instead, the user interface is displayed in the language of the local computer that is running IIS Manager.

For example, the language of the local computer is French, and the language of the IIS 7.0 server is English. When you connect to the IIS 7.0 server, IIS Manager displays the user interface in French instead of in English.

CAUSE

This issue occurs because of a problem in IIS Manager that causes it to incorrectly send satellite assemblies during code download.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have IIS 7.0 installed to apply this hotfix. You must install this hotfix on Windows Vista Service Pack 1 (SP1) or on Windows Server 2008.

Restart requirement

You must restart your computer if IIS Manager is running when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.web.management.aspnetclient.dll6.0.6001.22426462,84806-May-200914:22x86
Microsoft.web.management.dll6.0.6001.224261,036,28806-May-200914:22x86
Microsoft.web.management.dll6.0.6002.221291,036,28806-May-200914:11x86
Microsoft.web.management.aspnet.dll6.0.6001.22426135,16806-May-200914:22x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.web.management.aspnetclient.dll6.0.6001.22426462,84806-May-200915:57x86
Microsoft.web.management.dll6.0.6001.224261,036,28806-May-200915:57x86
Microsoft.web.management.dll6.0.6002.221291,036,28806-May-200914:50x86
Microsoft.web.management.aspnet.dll6.0.6001.22426135,16806-May-200915:57x86
For all supported Itanium-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.web.management.aspnetclient.dll6.0.6001.22426462,84806-May-200915:36x86
Microsoft.web.management.dll6.0.6001.224261,036,28806-May-200915:36x86
Microsoft.web.management.dll6.0.6002.221291,036,28806-May-200913:47x86
Microsoft.web.management.aspnet.dll6.0.6001.22426135,16806-May-200915:36x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about satellite assemblies, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/70s77c20(VS.71).aspx (http://msdn.microsoft.com/en-us/library/70s77c20(VS.71).aspx)

APPLIES TO
  • Microsoft Internet Information Services 7.0
Keywords: 
kbhotfixserver kbautohotfix kbexpertiseadvanced kbqfe kbsurveynew KB970772