Un ordinateur qui exécute Windows Server 2003 R2 SP2 prend en charge l'IPMI standard blocage lorsque l'ordinateur écrit un fichier d'image mémoire

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Sommaire

Symptômes

Envisagez le scénario suivant :
  • Vous disposez d'un ordinateur qui exécute Windows Server 2003 Service Pack 2 (SP2) qui prend en charge la norme IPMI (Intelligent Platform Management Interface).
  • L'ordinateur écrit un fichier de vidage de mémoire en raison d'un problème de (écran bleu) d'erreur stop.
  • Lorsque l'ordinateur écrit le fichier de vidage, la mémoire disponible est faible.
Dans ce scénario, l'ordinateur cesse de répondre pendant qu'il écrit le fichier de vidage. Si vous attachez un outil de débogage à l'ordinateur, vous trouvez que le code d'erreur stop 0x000000D1 lorsque l'ordinateur cesse de répondre.

Dans ce cas, l'ordinateur qui exécute Windows Server 2003 ne peut pas récupérer automatiquement. En outre, l'ordinateur ne peut pas écrire un fichier de vidage mémoire pour les problèmes d'erreur stop. Par conséquent, vous devez forcer l'arrêt de l'ordinateur ou redémarrez l'ordinateur.

Cause

Ce problème est dû à une erreur dans le pilote IPMIdrv.sys.

Code en cours d'exécution à l'IRQ avec des privilèges élevés au niveau (HIGH_LEVEL) ne soient pas paginable. Toutefois, dans le pilote IPMIdrv.sys, du code qui s'exécute au niveau IRQ avec des privilèges élevés (HIGH_LEVEL) est paginable. Si le code est renvoyée lorsque le système essaie d'exécuter le code, le code ne peut pas être pagé dans car, au niveau d'IRQ avec des privilèges élevés, le système ne peut pas traiter une page de la demande ou page demande. Par conséquent, l'ordinateur ne peut pas accéder au code et l'ordinateur déclenche le code d'arrêt (0x000000d1) deuxième mentionné dans la section «Symptômes».

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible au téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettez une demande service clientèle Microsoft et de support technique pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions supplémentaires et aux problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète des numéros de téléphone Microsoft auprès des services de support technique ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, votre ordinateur doit exécuter Windows Server 2003 Service Pack 2.

La nécessité de redémarrer

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement du correctif

Ce correctif ne remplace aucun autre correctif préalablement publié.

Informations de fichier

La version anglaise de ce correctif possède les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour connaître le décalage entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire de l'élément de date et heure dans le panneau de configuration.
Pour toutes les x 86 versions Windows Server 2003 SP2
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipmidrv.sys5.2.3790.450657,34430 Avril 200913 : 03x 86
Pour toutes les versions Itanium de Windows Server 2003 SP2 prises en charge
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipmidrv.sys5.2.3790.4506136,70430 Avril 200914 : 47IA-64
Pour toutes les versions 64 de Windows Server 2003 SP2 x
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipmidrv.sys5.2.3790.450686 01630 Avril 200914 : 48x 64

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "S'applique à".

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 970810 - Dernière mise à jour: lundi 15 juin 2009 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Mots-clés : 
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