Um computador que executa o Windows Server 2003 R2 SP2 que suporta as paradas IPMI padrão responder quando o computador está gravando um arquivo de despejo de memória

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Sintomas

Considere o seguinte cenário:
  • Você tem um computador que esteja executando o Windows Server 2003 Service Pack 2 (SP2) que dá suporte ao padrão Intelligent Platform Management Interface (IPMI).
  • O computador grava um arquivo de despejo de memória devido a um problema de (tela azul) de erro de parada do.
  • Quando o computador está gravando o arquivo de despejo, a memória disponível é insuficiente.
Nesse cenário, o computador pára de responder enquanto ele está gravando o arquivo de despejo. Se você anexar uma ferramenta de depuração para o computador, você achar que o código de erro stop é 0x000000D1 quando o computador pára de responder.

Nesse caso, o computador que está executando o Windows Server 2003 não é possível recuperar automaticamente. Além disso, o computador não é possível gravar um arquivo de despejo de memória para problemas de erro de parada. Portanto, é necessário que forçar o desligamento do computador ou reinicie o computador.

Causa

Esse problema é causado por um erro no driver IPMIdrv.sys.

Com o IRQ elevado nível de código (HIGH_LEVEL) não deve ser paginável. No entanto, no driver IPMIdrv.sys, algum código que é executado no nível de IRQ elevado (HIGH_LEVEL) é paginável. Se o código é paginado quando o sistema tenta executar o código, o código não pode ser paginado no porque, no nível de IRQ elevado, o sistema não pode processar uma página na solicitação ou página da solicitação. Portanto, o computador não é possível acessar o código e o computador dispara o código stop segundo (0x000000d1) mencionado na seção "Sintomas".

Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibido, envie uma solicitação de suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando o Windows Server 2003 Service Pack 2.

Requisito de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para todas as versões de 86 Windows Server 2003 SP2 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Ipmidrv.sys5.2.3790.450657.34430-Abr-200913: 03x 86
Para todas as versões com base em Itanium do Windows Server 2003 SP2
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Ipmidrv.sys5.2.3790.4506136,70430-Abr-200914: 47IA-64
Para todas as versões com base em 64 Windows Server 2003 SP2 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Ipmidrv.sys5.2.3790.450686,01630-Abr-200914: 48x 64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão usada para descrever as atualizações de software

Propriedades

ID do artigo: 970810 - Última revisão: segunda-feira, 15 de junho de 2009 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Palavras-chave: 
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Tradução automática
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