С помощью Process Explorer список библиотек DLL запущенный под процесс Outlook.exe

Переводы статьи Переводы статьи
Код статьи: 970920 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все
Источник: Поддержка Майкрософт

БЫСТРАЯ ПУБЛИКАЦИЯ

БЫСТРАЯ ПУБЛИКАЦИЯ ДАННЫХ СОДЕРЖАТСЯ СВЕДЕНИЯ НЕПОСРЕДСТВЕННО В СЛУЖБУ ТЕХНИЧЕСКОЙ ПОДДЕРЖКИ МАЙКРОСОФТ ОРГАНИЗАЦИИ. СВЕДЕНИЯ, СОДЕРЖАЩИЕСЯ В НАСТОЯЩЕМ ДОКУМЕНТЕ СОЗДАЕТСЯ В ОТВЕТ НА НОВЫХ ИЛИ УНИКАЛЬНЫЙ РАЗДЕЛЫ, ИЛИ ПРЕДНАЗНАЧЕНА ДОПОЛНЕНИЯ ДРУГИХ ЗНАНИЙ СВЕДЕНИЯ.

Симптом

Программа Process Explorer — это служебная программа, которая предоставляет сведения о какой дескрипторов и библиотек DLL каждый процесс имеет открыть. В контексте устранения неполадок Outlook Process Explorer обычно используется для определения при наличии любых сторонних библиотек DLL, под процесс Outlook.exe. Это важный шаг вызывает вероятность того, что надстройки или другие программы на компьютере может быть причиной возникновения проблем в Outlook.

В этой статье приводятся сведения о использовании Process Explorer для вывода всех dll-файлов, под процесс Outlook.exe.

Дополнительные сведения



Получение Process Explorer

Во-первых — это получение последней версии Process Explorer. Ее можно загрузить с узла Microsoft TechNet по адресу:

http://technet.microsoft.com/ru-ru/sysinternals/bb896653.aspx

Обязательно прочтите информацию на эту страницу, чтобы представить себе этот инструмент.
 

Работающих процессах проводника

После загрузки и извлечения Process Explorer, выполните следующие действия, чтобы собрать список библиотек DLL, под процесс Outlook.exe.

1. Запустите Outlook.

2. Дважды щелкните Procexp.exe, чтобы запустить Process Explorer.

3. В меню «Вид» убедитесь, что установлен флажок «Показать нижнюю область».

4. Нажмите клавиши CTRL + D или нажмите кнопку режиме - нижней панели - DLL, чтобы включить режим просмотра библиотеки DLL.

5. В верхней области Process Explorer прокрутите вниз список файлов, а затем выберите файл Outlook.exe.

6. После списка библиотек DLL, выполняемый файл Outlook.exe, перечислены в нижней части окна, выберите команду Сохранить как в меню файл.

7. Сохраните файл с именем Outlook.exe.txt.

 
Анализ выходных данных процесса Explorer

Выходной текстовый файл является разделенный табуляцией текстовый файл, который наилучшим образом открыть в Microsoft Excel, что позволяет быстро находить все библиотеки DLL не корпорацией Майкрософт, загруженные с помощью функции фильтра.

1. Запустите программу Microsoft Office Excel и откройте Outlook.exe.txt.

2. В окне мастера импорта текста используйте следующие параметры:
• С разделителями
• Вкладка разделитель
• Общие столбца данных формата
3. Прокрутите лист вниз и найдите следующую строку:

Название компании Описание имя версии

Это список всех библиотек DLL (корпорации Майкрософт и сторонних производителей) выполняемый процесс Outlook.exe.

4. Выберите ячейку с «Имя» над списком библиотек DLL, а затем включите функцию фильтрации.

5. Нажмите кнопку раскрывающегося списка фильтр в поле «имя», а затем настройте текстовый фильтр со следующими параметрами:

Имя – содержит - .dll
 
6. Выберите фильтр раскрывающегося списка в поле название компании, а затем снимите флажки, содержащее «Microsoft».

 
Идентификация Microsoft и 3-й библиотеки сторонних производителей
 
Отфильтрованный список библиотек DLL, отображаются с помощью приведенных выше шагов будет содержать 3-й библиотек DLL сторонних производителей, выполняется в Microsoft Outlook. Можно проверить столбец имя компании для определения поставщика, ответственного за dll-файла.

В списке фильтров из библиотеки DLL также существуют некоторые из библиотек DLL, поставляемые с Microsoft Outlook, не отображаются в столбце Имя компании «Microsoft». Чтобы определить эти библиотеки DLL Microsoft, выполните следующие действия:


Outlook 2010

1. Запустите Outlook 2010.

2. Перейдите на вкладку «файл» на ленте, а затем нажмите кнопку Параметры.

3. В диалоговом окне Параметры Outlook выберите команду надстройки.

4. Чтобы проверить надстройки COM, выберите в раскрывающемся списке управление COM-надстройки и нажмите кнопку Перейти.

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя DLL-файла в папке: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.


Outlook 2007

1. Запустите Outlook 2007.

2. В меню Сервис выберите центр управления безопасностью.

3. В центре управления безопасностью щелкните надстройки.

4. Чтобы проверить надстройки COM, выберите в раскрывающемся списке управление COM-надстройки и нажмите кнопку Перейти.

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя DLL-файла в папке: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.

 
Outlook 2003 и более ранних версий

1. Запустите Outlook 2003.

2. В меню Сервис выберите команду Параметры.

3. На вкладке Дополнительно нажмите кнопку Дополнительные параметры.

4. Нажмите кнопку "надстройки COM".

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя DLL-файла в папке: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.


ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ

MICROSOFT И/ИЛИ ЕЕ ПОСТАВЩИКИ НЕ ДЕЛАТЬ ПРЕДСТАВЛЕНИЯ ИЛИ ГАРАНТИЙ О ПРИГОДНОСТИ, НАДЕЖНОСТЬ И ТОЧНОСТЬ ИНФОРМАЦИИ СОДЕРЖАТСЯ В ДОКУМЕНТЫ И СВЯЗАННЫХ РИСУНКОВ ПУБЛИКАЦИИ НА ЭТОМ ВЕБ-САЙТЕ (ДАЛЕЕ "МАТЕРИАЛЫ") ДЛЯ ЛЮБЫХ ЦЕЛЕЙ. МАТЕРИАЛЫ МОГУТ СОДЕРЖАТЬ ТЕХНИЧЕСКИЕ НЕТОЧНОСТИ ИЛИ ОПЕЧАТОК И МОЖЕТ БЫТЬ ИЗМЕНЕН В ЛЮБОЕ ВРЕМЯ БЕЗ ПРЕДВАРИТЕЛЬНОГО УВЕДОМЛЕНИЯ.

В МАКСИМАЛЬНОЙ СТЕПЕНИ, ДОПУСКАЕМОЙ ПРИМЕНИМО ЗАКОНОДАТЕЛЬСТВОМ, КОРПОРАЦИЯ МАЙКРОСОФТ ИЛИ ЕЕ ПОСТАВЩИКИ DISCLAIM И ИСКЛЮЧИТЬ ВСЕ ПРЕДСТАВЛЕНИЯ ГАРАНТИЙ И УСЛОВИЙ ЛИ EXPRESS, КОСВЕННЫХ ИЛИ УСТАНОВЛЕННЫХ ЗАКОНОМ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЕТСЯ, ГАРАНТИЙ, УСЛОВИЙ ИЛИ ЗАГОЛОВКА, ОТЛИЧНЫХ ОТ КОНТРАФАКЦИИ, ИСПРАВИВ ОШИБКУ ИЛИ КАЧЕСТВА, ЛЮБЫЕ ГАРАНТИИ ТОВАРНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЕННОЙ ЦЕЛИ, ОТНОСЯЩИЕСЯ К МАТЕРИАЛАМ.
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 970920 - Последний отзыв: 19 июня 2011 г. - Revision: 4.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Outlook 2003
  • Microsoft Office Outlook 2007
Ключевые слова: 
kbrapidpub kbnomt kbmt KB970920 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:970920

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com