Update: SNA Manager aktualisiert nicht die "User Name" "Client" und "Exe-Name" Spalten bei der Anzeige des aktiven Status APPC-LU in Host Integration Server

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Artikel-ID: 971130 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Sie öffnen in einer Umgebung mit Microsoft Host Integration Server SNA-Manager. Dann erweitern Sie den Knoten Lokale APPC-LU zum Anzeigen des Status der aktiven Local Advanced Program-to-Program Communication (APPC) logischen Einheiten (LUs). Stellen Sie fest, dass der Status für eine aktive lokale APPC-LU folgenden Inhalts angezeigt:
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Partner-LUModusBenutzernameClientModus beschränkenExe-Name
REMOTE1-INTER<Nicht Benutzt >n/v8n/v
REMOTE2-INTER<Nicht Benutzt >n/v8n/v

Ursache

Wenn eine Sitzung zum ersten Mal eingerichtet ist, über eine lokale APPC LU, die "Benutzername", "Client", und "Exe-Name" Spalten enthalten Informationen, die den Benutzer zu identifizieren, der die Sitzung, den Namen des Computers des Benutzers und den Namen der ausführbaren Datei der Anwendung, die die Sitzung initiiert. Diese Informationen werden jedoch nie für alle späteren APPC aktualisiert Unterhaltungen, die während der gleichen APPC-Sitzung gestartet werden.

Hinweis:Der APPC-LU-Status wird aktualisiert, um diese Informationen entfernen, unmittelbar nach die anfängliche Unterhaltung über die APPC-Sitzung beendet.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems, die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar", am Anfang dieses Knowledge Base-Artikels. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft-Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Sie müssen die Host Integration Server 2004 installiert haben, um diesen Hotfix anwenden können.

Neustartanforderung

Sie müssen den Computer neu zu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Updates besitzt die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet sind. Die Datums- und Uhrzeitangaben für diese Dateien sind aufgelistet, in Coordinated Universal Time (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, in dem Element für Datum und Uhrzeit in der Systemsteuerung die Registerkarte Zeitzone.
Host Integration Server 2004
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DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Mmcsna.dll6.0.2443.0258,36811-Sep 200921: 28X 86SP2
Mngsna.dll6.0.2443.0101,71211-Sep 200921: 28X 86SP2
Snaole.dll6.0.2443.0635,21611-Sep 200921: 28X 86SP2

Hinweis: Aufgrund von Dateiabhängigkeiten kann die neuesten Updates, die diese Dateien enthält auch weitere Dateien enthalten.

Status

Microsoft hat bestätigt, dass dies ein Problem in der Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Wichtig In diesem Abschnitt, eine Methode oder eine Aufgabe enthält Hinweise zum Ändern der Registrierung. Jedoch können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie deshalb sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie Änderungen vornehmen. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie die folgende KB-Artikelnummer:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows
Nachdem Sie dieses Update angewendet haben, können Sie in Echtzeit Statusaktualisierungen für APPC LUs im SNA-Manager aktivieren. Fügen Sie hierzu einen UpdateStatus Registrierungseintrag gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie Regedit ein, und klicken Sie dann auf OK.
  2. Gehen Sie zu folgendem Registrierungsschlüssel:
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SnaBase/Parameters
  3. Klicken Sie mit der rechten Maustaste auf Parameters, zeigen Sie auf neu, und klicken Sie dann auf Zeichenfolge.
  4. Geben Sie als Namen des Registrierungsschlüssels UpdateStatus, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie im Menü Bearbeiten auf Ändern.
  6. Geben Sie im Feld Wertdaten1 ein, und klicken Sie dann auf OK.
  7. Schließen Sie den Registrierungseditor.
Hinweis:Diese Änderung wirksam wird, Sie müssen neu starten, damit die SNABASE-Dienst.

In Umgebungen, in denen viele APPC LUs und viele kurzlebige Transaktionen von APPC verfügen, kann die Anzahl der APPC-LU Statusaktualisierungen sehr hoch sein. In solchen Umgebungen können in Echtzeit Statusaktualisierungen für APPC LUs Bildschirm Update Probleme verursachen, wenn Sie SNA-Manager anzeigen. Wenn diese Probleme auftreten, müssen Sie möglicherweise den UpdateStatus-Registrierungsparameter, die in Echtzeit Statusaktualisierungen für APPC LUs deaktivieren zu entfernen.

Eigenschaften

Artikel-ID: 971130 - Geändert am: Donnerstag, 4. Februar 2010 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Host Integration Server 2004 Enterprise Edition
  • Microsoft Host Integration Server 2004 Standard Edition
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
  • Microsoft Host Integration Server 2009
Keywords: 
kbmt kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe kbhotfixserver KB971130 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 971130
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