CORRECÇÃO: SNA Manager não atualiza o "nome de usuário", "Client" e "Nome do executável" colunas quando você exibir o status de APPC LU ativo no Host Integration Server

Traduções deste artigo Traduções deste artigo
ID do artigo: 971130 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Em um ambiente Microsoft Host Integration Server, abra o Gerenciador de SNA. Em seguida, você expandir o nó Local APPC LU para exibir o status do ativo local avançada programa a programa Communication (APPC) unidades lógicas (lu). Você observar o status de uma LU existente ativo APPC local semelhante à seguinte:
Recolher esta tabelaExpandir esta tabela
Parceiro LUModoUsuário nomeClienteLimite de modoNome exe
REMOTE1# INTER<Não Em Uso >n/d8n/d
REMOTE2# INTER<Não Em Uso >n/d8n/d

Causa

Quando uma sessão é estabelecida pela primeira vez em um local APPC LU, o "nome de usuário", "Client" e "Nome do executável" colunas contêm informações que identificam o usuário que iniciou a sessão, o nome do computador do usuário e o nome do executável de aplicativo que está usando a sessão. No entanto, essas informações nunca são atualizadas para qualquer APPC posterior conversas são iniciadas durante a mesma sessão APPC.

Observação:O status de APPC LU é atualizado para remover essas informações imediatamente depois da conversa inicial em sessão APPC termina.

Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibido, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Você deve ter o Host Integration Server 2004 para aplicar esse hotfix.

Requisito de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas em hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
O Host Integration Server 2004
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Mmcsna.dll6.0.2443.0258,36811 De setembro de 200921: 28x 86SP2
Mngsna.dll6.0.2443.0101,71211 De setembro de 200921: 28x 86SP2
Snaole.dll6.0.2443.0635,21611 De setembro de 200921: 28x 86SP2

Observação: Devido às dependências do arquivo, a correção mais recente que contém esses arquivos também pode conter arquivos adicionais.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Importante Nesta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
Depois de aplicar essa atualização, você pode ativar as atualizações de status em tempo real para APPC LUs SNA Manager. Para fazer isso, adicione um UpdateStatus entrada do registro seguindo essas etapas:
  1. Clique em Iniciar, clique em Executar, digite regedit e, em seguida, clique em OK.
  2. Localize a seguinte chave do registro:
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/SnaBase/Parameters
  3. Clique com o botão direito do mouse em Parameters, aponte para novo e, em seguida, clique em Valor de string.
  4. Digite UpdateStatus como o nome da chave do registro e pressione ENTER.
  5. No menu Editar, clique em Modificar.
  6. No campo de dados do valor, digite 1 e, em seguida, clique em OK.
  7. Feche o Editor do registro.
Observação:Para que esta alteração tenha efeito, reinicie o SNABASE serviço.

Em ambientes que têm muitos LUs APPC e muitas transações APPC curta duração, o número de atualizações de status de APPC LU pode ser muito alto. Nesses ambientes, atualizações de status em tempo real para APPC LUs podem causar problemas de atualização de tela quando você exibir SNA Manager. Se esses problemas ocorrem, talvez seja necessário remover o parâmetro de registro UpdateStatus para desativar as atualizações de status em tempo real para APPC LUs.

Propriedades

ID do artigo: 971130 - Última revisão: quinta-feira, 4 de fevereiro de 2010 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2004 Enterprise Edition
  • Microsoft Host Integration Server 2004 Standard Edition
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
  • Microsoft Host Integration Server 2009
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe kbhotfixserver KB971130 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 971130

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com