A variável de ambiente CLIENTNAME retorna o valor "Console" em vez do nome real do cliente quando os usuários primeiro fazer logon em um computador com Windows XP SP3 usando a conexão de área de trabalho remota

Traduções deste artigo Traduções deste artigo
ID do artigo: 971165 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • Você tiver um computador com Windows XP Service Pack 3 (SP3) instalado.
  • Permitir usuários se conectem remotamente ao computador usando a conexão de área de trabalho remota (RDC).
  • Na primeira tentativa de logon depois de reiniciar o computador, use RDC em vez de um logon no console.
Depois de conectar o computador de um computador remoto neste cenário, a variável de ambiente CLIENTNAME é definida para "Console" em vez de para o nome do computador remoto. Portanto, programas ou scripts que dependem da variável de ambiente CLIENTNAME não funcionam conforme o esperado.

anotações
  • Para verificar o valor para a variável de ambiente CLIENTNAME, digite o seguinte comando em um prompt de comando e, em seguida, pressione ENTER:
    Definir
  • Você pode fazer logoff e logon no computador para receber o valor correto para a variável de ambiente CLIENTNAME. No entanto, quando você reinicia o computador, esse problema pode se repetir.
  • Se o hotfix descrito no artigo Microsoft Knowledge Base (KB) 281981 for aplicado ao computador, a variável de ambiente CLIENTNAME é atualizada corretamente após você desconecta e reconectar à sessão de conexão de área de trabalho remota.
Para obter mais informações sobre o artigo 281981, consulte a seção "Informações MORE".

Causa

Quando você estabelece uma sessão de conexão de área de trabalho remota, os serviços de terminal atualiza a entrada de registro clientname no seguinte local:
Ambiente HKEY_CURRENT_USER\Volatile
A variável de ambiente CLIENTNAME usará o valor que é armazenado neste local.

Se você usar a conexão de área de trabalho remota para se conectar a um computador baseado no Windows XP SP3, serviços de terminal não atualiza a entrada de registro clientname na primeira tentativa de logon porque o perfil de usuário não é completamente carregado. Os serviços de terminal não tenta atualizar a entrada de registro clientname novamente após a primeira tentativa de logon. Por isso, a entrada de registro clientname não é atualizada com êxito.

Resolução

Para resolver esse problema, instale o seguinte hotfix. Depois de instalar esse hotfix, o sistema repete várias vezes para gravar a entrada de registro clientname com valor correto na primeira tentativa de logon. Portanto, você deve receber o valor correto para a variável de ambiente CLIENTNAME.

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 3 instalado no computador.Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix substitui o seguinte hotfix:
281981Sessões desconectadas retém a variável <clientname> original

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com Service Pack 3, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.1.2600.5815296,96018-Mai-200915: 55x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
281981Sessões desconectadas retém a variável <clientname> original

Propriedades

ID do artigo: 971165 - Última revisão: sexta-feira, 3 de julho de 2009 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Service Pack 3 para Windows XP nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbhotfixserver KB971165 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 971165

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com