Pokud se aplikace pokusí zapsat data sdílený soubor, pokud jiná aplikace má přístup jen pro čtení stejný soubor v počítači se systémem Windows Server 2003 se zobrazí chybová zpráva: "Odložený zápis nepodařilo"

Překlady článku Překlady článku
ID článku: 971295 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme následující situaci:
  • Máte sdílený soubor v počítači se systémem Windows Server 2003.
  • Dvě aplikace přístup souběžně sdíleného souboru. Jedna aplikace má přístup pro zápis do souboru a dalších aplikací má přístup jen pro čtení k souboru.
Po určitou dobu spuštění obě aplikace, například několik hodin, nemůže aplikace má přístup pro zápis zapsat data sdílený soubor a obdrží chybovou zprávu "Odložený zápis nepodařilo" této aplikace. Tento problém způsobuje ztrátu dat nebo poškození dat v sdílený soubor.

Příčina

K tomuto problému dochází z důvodu problému časování v ovladači přesměrovány Drive ukládání do vyrovnávací paměti podsystém (Rdbss.sys). Když nastane problém časování mezipaměti data sdílený soubor vyprázdněna pomocí objektu nesprávný soubor. Tento soubor objekt nemá přístup jen pro čtení.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Tuto opravu hotfix, musí být počítač spuštěn Windows Server 2003 Service Pack 1 (SP1) nebo Windows Server 2003 Service Pack 2 (SP2).

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné dříve vydané opravy hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Pro všechny podporované x 86 verze systému Windows Server 2003 SP1
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377177,66415 VII 200915: 10X86
Pro všechny podporované verze 86 Windows Server 2003 SP2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552177,66415 VII 200914: 58X86
Pro všechny podporované-verze x 64 Windows Server 2003 a Windows XP
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377309,24816 VII 200914: 12X64
Pro všechny podporované-verze x 64 Windows Server 2003 SP2 a této aktualizace
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552309,76016 VII 200914: 18X64
Pro všechny podporované verze systému Windows Server 2003 SP1 pro procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377487,93616 VII 200914: 12IA-64
Pro všechny podporované verze systému Windows Server 2003 SP2 S procesorem Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552487,93616 VII 200914: 16IA-64

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 971295 - Poslední aktualizace: 6. srpna 2009 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB971295 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:971295

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com