当应用程序尝试将数据写入共享的文件,如果另一个应用程序正在运行 Windows Server 2003 的计算机上对同一文件具有只读访问权限时出现错误消息:"延迟写入失败"

文章翻译 文章翻译
文章编号: 971295 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

请考虑以下情形:
  • 您有运行 Windows Server 2003 的计算机上的共享的文件。
  • 两个应用程序同时访问此共享的文件。一个应用程序文件,具有写访问权限和其他应用程序对文件具有只读访问权限。
这两个应用程序运行段时间后,不如几个小时的时间具有写访问权限的应用程序能把数据写到该共享文件,此应用程序收到"延迟写入失败"的错误消息。共享文件中,此问题导致数据丢失或数据损坏。

原因

出现此问题是由于重定向驱动器缓冲子系统 (Rdbss.sys) 驱动程序中的计时问题。计时问题时,共享文件的缓存数据的刷新,通过使用错误的文件对象。此文件对象具有只读访问权限。

解决方案

修补程序信息

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现这一特定问题的系统。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果未出现本部分,将申请提交到 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。

系统必备组件

若要将此修补程序必须运行您的计算机,Windows Server 2003 Service Pack 1 (SP1) 或 Windows Server 2003 Service Pack 2 (SP2)。

重新启动要求

应用此修补程序后,您必须重新启动计算机。

修补程序替换信息

此修补程序不替代任何其他以前发布的修补程序。

文件信息

此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的 日期和时间 项中的 时区 选项卡。
支持所有 x 基于 x86 的 Windows Server 2003 SP1 的版本
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.3377177,6642009 年七月 15 日15: 10x86
支持所有 x 基于 x86 的 Windows Server 2003 SP2 的版本
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.4552177,6642009 年七月 15 日14: 58x86
所有支持基于 x64 的版本的 Windows Server 2003 和 Windows XP 的 x
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.3377309,2482009 年七月 16 日14: 12x64
所有支持基于 x64 的版本和 Windows XP SP2 的 Windows Server 2003 SP2 x
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.4552309,7602009 年七月 16 日14: 18x64
对所有受支持的 Windows Server 2003 SP1 的基于 Itanium 的版本
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.3377487,9362009 年七月 16 日14: 12IA 64
所有受支持的基于 Itanium 的版本,Windows Server 2003 SP2 的
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Rdbss.sys5.2.3790.4552487,9362009 年七月 16 日14: 16IA 64

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

更多信息

有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684 用于描述 Microsoft 软件更新的标准术语的说明

属性

文章编号: 971295 - 最后修改: 2009年8月6日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Standard Edition
关键字:?
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB971295 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 971295
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com