Después de instalar la actualización de seguridad 938464 en Windows XP, experimenta un rendimiento lento y excepciones de primera oportunidad en aplicaciones que utilizan GDI + para los archivos GIF de proceso

Seleccione idioma Seleccione idioma
Id. de artículo: 971320 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Instalar actualización de seguridad 938464 (MS08-052) para Microsoft GDI + en un equipo que ejecuta Windows XP.
  • Utilice un depurador o una herramienta de comprobación en tiempo de ejecución, como AppSight, para probar una aplicación que utiliza Microsoft GDI + para procesar archivos de formato de intercambio de gráficos (GIF).
En este escenario, la aplicación responde lentamente. Además, el depurador o la herramienta de comprobación en tiempo de ejecución informar errores de excepción de primero oportunidad.

Causa

El códec GIF en GDI + 1.0 codifica imágenes GDI + que tienen 256 o menos colores (8 bits por píxel). El códec GIF utiliza información de error de excepción para descodificar imágenes GIF. Por lo tanto, puede experimentar infracciones de acceso cuando utiliza una herramienta de comprobación en tiempo de ejecución para supervisar un programa GDI + que utiliza el códec GIF.

Solución

Nota Todavía pueden informar de errores de excepción de página de protección después de aplicar este hotfix. Para evitar el problema, deshabilite la excepción de página de protección detectar en el depurador o en la herramienta de comprobación en tiempo de ejecución.

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows XP Service Pack 3 (SP3). Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información del registro

Para utilizar una de las revisiones de este paquete, no es necesario realizar cambios en el registro.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Gdiplus.dll5.2.6002.221651,748,99201-Sep-200913: 30x 86
Gdiplus.manNo aplicable39801-Sep-200913: 32No aplicable
Gdiplus.manNo aplicable60801-Sep-200913: 32No aplicable

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Referencias

Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, sobre el rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 971320 - Última revisión: miércoles, 14 de octubre de 2009 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe kbhotfixserver KB971320 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 971320

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com