Exchange Server 2007 users intermittently cannot access an Exchange Server 2003 user's Free/Busy information in Office Outlook 2007

Article translations Article translations
Article ID: 971349 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • In a mixed Microsoft Exchange Server 2003 and Microsoft Exchange Server 2007 environment, you have more than one Administrative Group. The network connections between these Administrative Groups are low in bandwidth.
  • Public Folder replication is scheduled among the Administrative Groups.
  • An Exchange Server 2007 user creates an appointment or a meeting request in Microsoft Office Outlook 2007. Then, the Exchange Server 2007 user invites an Exchange Server 2003 user to this appointment or meeting as an attendee.
  • The Exchange Server 2003 attendee belongs to a different AG than the Exchange Server 2007 user.
  • The Exchange Server 2007 user checks the Free/Busy information in Office Outlook 2007.
In this scenario, the Exchange Server 2007 user intermittently cannot access the Exchange Server 2003 server user's Free/Busy information.

CAUSE

If a user in an Exchange Server 2007 Administrative Group requests the Free/Busy information for a user in an Exchange Server 2003 Administrative Group, Exchange Server 2007 Client Access Service (CAS) uses an Exchange Web Service (EWS) proxy. Therefore, the request may use the low bandwidth connection to the Exchange Server 2003 Administrative Group. In this case, the Free/Busy information may be unavailable intermittently because of the low network bandwidth.

RESOLUTION

To resolve this problem, follow these steps:
  1. Install Update Rollup 2 for Exchange Server 2007 Service Pack 2 on the Exchange server.
    972076 Description of Update Rollup 2 for Exchange Server Service Pack 2
  2. Locate the Web.config file in the following folder:
    %ProgramFiles%\Microsoft\Exchange Server\ClientAccess\exchweb\EWS
  3. Open the Web.config file in Notepad, and then locate and add the following line between the <appsettings> element and the </appsettings> element:
    <add key="UseLocalReplicaForFreeBusy" value="true" />

    Note If the value of the key "UseLocalReplicaForFreeBusy" is true, Exchange Server 2007 CAS checks if there is a replica for the Exchange Server 2003 users on a local public folder server. If there is a replica available, Exchange Server 2007 CAS uses the replica instead of a low bandwidth WAN connection.
  4. Save the Web.config file and then restart the Exchange Web Service on the Exchange Server 2007 server.
  5. Do the same change in the Web.config file located in:
    %ProgramFiles%\Microsoft\Exchange Server\ClientAccess\OWA

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 971349 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbsurveynew kbqfe kbfix kbexpertiseinter kbhotfixrollup KB971349

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com