Schutzaufträge für verschiedene geschützte Server schlagen mit Fehlern fehl

Dieser Artikel hilft Ihnen, Fehlermeldungen zu Details zu fehlgeschlagenen Aufträgen für verschiedene geschützte Server in Data Protection Manager (DPM) zu beheben.

Ursprüngliche Produktversion: System Center Data Protection Manager
Ursprüngliche KB-Nummer: 971411

Problembeschreibung

Sie erhalten eine oder mehrere der folgenden Fehlermeldungen zu fehlgeschlagenen Aufträgen für verschiedene geschützte Server in System Center Data Protection Manager. Diese Fehler können bei verschiedenen Arten von Aufträgen auftreten, einschließlich Synchronisierung, Wiederherstellungspunkten und Konsistenzprüfung.

Typ: WiederherstellungspunktStatus: Fehler Beschreibung: Während der Auftragsausführung ist ein unerwarteter Fehler aufgetreten. (ID 104 Details: Interner Fehlercode: 0x80990A51)

Typ: Bandsicherungsstatus: Fehler Beschreibung: DPM konnte nicht mit dem Schutz-Agent auf Server_name.com kommunizieren, da der Zugriff verweigert wurde. (ID 42 Details: Zugriff verweigert (0x80070005))

DPM konnte nicht mit dem Schutz-Agent-Dienst unter ProtectedServer.Contoso.local kommunizieren. (ID 308 Details: Der RPC-Server ist nicht verfügbar (0x800706BA))

Fehler beim Schutz-Agent-Vorgang, weil DPM nicht mit dem Schutz-Agent-Dienst auf protected.server.contoso.com kommunizieren konnte. (ID 308 Details: Der RPC-Server ist nicht verfügbar (0x800706BA))

Typ: Wiederherstellungspunktstatus: Fehler Beschreibung: Der Schutz-Agent auf Server_name.com konnte vorübergehend nicht reagieren, weil er sich in einem unerwarteten Zustand befand. (ID 60 Details: Interner Fehlercode: 0x809909B0)

Der DPM-Dienst konnte nicht mit dem Schutz-Agent auf ProtectedServer.Contoso.local kommunizieren. (ID 52 Details: Eine vorhandene Verbindung wurde vom Remotehost erzwungen geschlossen (0x80072746))

Der DPM-Dienst konnte nicht mit dem Schutz-Agent auf ProtectedServer.Contoso.local kommunizieren. (ID 52 Details: Der Semaphortimeoutzeitraum ist abgelaufen (0x80070079))

DPM konnte nicht mit dem Schutz-Agent auf ProtectedServer.Contoso.local kommunizieren, da der Agent nicht reagiert. (ID 43 Details: Interner Fehlercode: 0x8099090E)

DPM konnte nicht mit ProtectedServer.Contoso.local kommunizieren, da der Computer nicht erreichbar ist. (ID 41 Details: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer sie aktiv abgelehnt hat (0x8007274D))

Ursache

Dieses Problem tritt auf, wenn das Netzwerk eine hohe Latenz aufweist oder wenn das Netzwerk mit Datenübertragungen überlastet ist. Wenn diese Bedingungen erfüllt sind, wird der DCOM-Datenverkehr verzögert. Dies führt dazu, dass für die Agents zeitweilig ein Timeout auftritt.

Problemumgehung

Um dieses Problem zu umgehen, führen Sie die folgenden Schritte aus, um einige Registrierungseinträge auf dem DPM-Server und dem geschützten Server hinzuzufügen.

  1. Fügen Sie im Editor die folgenden Einträge in die Datei ein, und speichern Sie die Datei dann als DPMAgentTimeout.reg.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent]
    "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20
    "ConnectionNoActivityTimeout"=dword:00001c20
    "AbortAgentOnLockTimeout"=dword:00000001
    "CommandTimeout"=dword:1b7740
    
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
    "TcpMaxDataRetransmissions"=dword:00000010
    
  2. Klicken Sie mit der rechten Maustaste auf die datei DPMAgentTimeout.reg , und wählen Sie dann Zusammenführen aus.

  3. Starten Sie den DPMRA-Dienst oder den Server neu, damit die Änderungen wirksam werden.

Wenn das Problem weiterhin besteht, aktivieren Sie die DPM-Drosselung von 85 bis 90 Prozent, um sicherzustellen, dass bandbreite für DCOM-Aufrufe verfügbar ist. Sie können die Bandbreitendrosselung für jeden geschützten Server auf der Registerkarte Agents auf der Registerkarte Verwaltung aktivieren.

Weitere Informationen zu diesem TcpMaxDataRetransmissions Wert finden Sie unter Ändern des timeouts für die maximale TCP/IP-Neuübertragung. Führen Sie außerdem Antivirensoftware auf dem DPM-Server aus.

Weitere Informationen

Es gibt verschiedene Kanäle für die Steuerungs- und Dateninformationen, die zwischen dem DPM-Server und einem geschützten Server übergeben werden. Der Steuerungspfad verwendet den DCOM-Kanal (RPC), und der Datenpfad verwendet TCP/IP. Wenn der Datenpfad das Netzwerk vollständig übersättigt (auch für kurze Zeit), können DCOM-Aufrufe fehlschlagen. Wenn die Aufrufe fehlschlagen, führt dies dazu, dass der Auftrag fehlschlägt. Um dieses Problem zu vermeiden, aktivieren Sie die Drosselung für die geschützten Server, um die Netzwerknutzung des Datenpfads auf 85 Prozent zu beschränken.

Standardmäßig ist die Drosselung in DPM nicht aktiviert, da die Drosselung die Installation von Quality of Service (QoS) sowohl auf dem DPM-Server als auch auf dem geschützten Server erfordert.

Wenn das Problem durch die Einstellung von 85 Prozent nicht vollständig behoben wird, erhöhen Sie die Drosselungsebene des geschützten Servers, auf dem das Problem auftritt.

Wenn diese Lösung das Problem nicht behebt, ist der DPM-Server möglicherweise überlastet. Versuchen Sie, die Schutzgruppen neu zu organisieren, sodass Die Sicherungen gestaffelt sind oder Synchronisierungen zu gestaffelten Zeiten erfolgen.