I processi di protezione per vari server protetti hanno esito negativo con errori

Questo articolo consente di correggere i messaggi di errore relativi ai dettagli del processo non riuscito per vari server protetti in Data Protection Manager (DPM).

Versione originale del prodotto: System Center Data Protection Manager
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Sintomi

Vengono visualizzati uno o più dei messaggi di errore seguenti relativi ai processi non riusciti per vari server protetti in System Center Data Protection Manager. Questi errori possono verificarsi per vari tipi di processi, tra cui la sincronizzazione, i punti di ripristino e la verifica della coerenza.

Tipo: Stato punto di ripristino: Descrizione non riuscita: si è verificato un errore imprevisto durante l'esecuzione del processo. (ID 104 Dettagli: Codice di errore interno: 0x80990A51)

Tipo: Stato backup nastro: descrizione non riuscita: DPM non è riuscito a comunicare con l'agente protezione in Server_name.com perché l'accesso è negato. (DETTAGLI ID 42: Accesso negato (0x80070005))

DPM non è riuscito a comunicare con il servizio Agente protezione in ProtectedServer.Contoso.local. (DETTAGLI ID 308: Il server RPC non è disponibile (0x800706BA))

L'operazione dell'agente protezione non è riuscita perché DPM non è riuscito a comunicare con il servizio Agente protezione in protected.server.contoso.com. (DETTAGLI ID 308: Il server RPC non è disponibile (0x800706BA))

Tipo: stato del punto di ripristino: descrizione non riuscita: l'agente protezione in Server_name.com non è stato temporaneamente in grado di rispondere perché si trovava in uno stato imprevisto. (ID 60 Dettagli: Codice di errore interno: 0x809909B0)

Il servizio DPM non è riuscito a comunicare con l'agente protezione in ProtectedServer.Contoso.local. (ID 52 Dettagli: Una connessione esistente è stata chiusa forzatamente dall'host remoto (0x80072746))

Il servizio DPM non è riuscito a comunicare con l'agente protezione in ProtectedServer.Contoso.local. (DETTAGLI ID 52: Il periodo di timeout del semaforo è scaduto (0x80070079))

DPM non è riuscito a comunicare con l'agente protezione in ProtectedServer.Contoso.local perché l'agente non risponde. (ID 43 Dettagli: Codice di errore interno: 0x8099090E)

DPM non è riuscito a comunicare con ProtectedServer.Contoso.local perché il computer non è raggiungibile. (ID 41 Dettagli: Non è stato possibile effettuare alcuna connessione perché il computer di destinazione l'ha rifiutata attivamente (0x8007274D))

Causa

Questo problema si verifica se la rete riscontra una latenza elevata o se la rete è satura di trasferimenti di dati. Quando queste condizioni sono vere, il traffico DCOM viene ritardato. Ciò causa il timeout intermittente degli agenti.

Soluzione alternativa

Per risolvere questo problema, seguire questa procedura per aggiungere alcune voci del Registro di sistema nel server DPM e nel server protetto.

  1. Nel Blocco note incollare le voci seguenti nel file e quindi salvare il file come DPMAgentTimeout.reg.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent]
    "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20
    "ConnectionNoActivityTimeout"=dword:00001c20
    "AbortAgentOnLockTimeout"=dword:00000001
    "CommandTimeout"=dword:1b7740
    
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
    "TcpMaxDataRetransmissions"=dword:00000010
    
  2. Fare clic con il pulsante destro del mouse sul file DPMAgentTimeout.reg e quindi scegliere Unisci.

  3. Riavviare il servizio DPMRA o il server per rendere effettive le modifiche.

Se il problema persiste, abilitare la limitazione DPM dell'85-90% per assicurarsi che la larghezza di banda sia disponibile per le chiamate DCOM. È possibile abilitare la limitazione della larghezza di banda per ogni server protetto nella scheda Agenti nella scheda Gestione .

Per altre informazioni sul TcpMaxDataRetransmissions valore, vedere Come modificare il timeout massimo di ritrasmissione TCP/IP. Inoltre, eseguire il software antivirus nel server DPM.

Ulteriori informazioni

Esistono diversi canali per il controllo e le informazioni sui dati che passano tra il server DPM e un server protetto. Il percorso di controllo usa il canale DCOM (RPC) e il percorso dati usa TCP/IP. Se il percorso dati satura completamente la rete (anche per un breve periodo di tempo), le chiamate DCOM potrebbero non riuscire. Se le chiamate hanno esito negativo, il processo non riesce. Per evitare questo problema, abilitare la limitazione delle richieste per i server protetti per limitare l'utilizzo della rete del percorso dati all'85%.

Per impostazione predefinita, la limitazione non è abilitata in DPM perché la limitazione richiede l'installazione di QoS (Quality of Service) sia nel server DPM che nel server protetto.

Se l'impostazione dell'85% non risolve completamente il problema, aumentare il livello di limitazione del server protetto che presenta il problema.

Se questa soluzione non risolve il problema, il server DPM potrebbe essere sovraccarico. Provare a riorganizzare i gruppi protezione dati in modo che i backup siano sfalsati o in modo che le sincronizzazioni vengano eseguite in momenti sfalsati.