さまざまな保護されたサーバーの保護ジョブがエラーで失敗する
この記事では、Data Protection Manager (DPM) のさまざまな保護されたサーバーの失敗したジョブの詳細に関するエラー メッセージを修正するのに役立ちます。
元の製品バージョン: System Center Data Protection Manager
元の KB 番号: 971411
現象
System Center Data Protection Manager で、さまざまな保護されたサーバーの失敗したジョブに関する次のエラー メッセージが 1 つ以上表示されます。 これらのエラーは、同期、復旧ポイント、整合性チェックなど、さまざまな種類のジョブで発生する可能性があります。
型: 復旧ポイントの状態: 失敗した説明: ジョブの実行中に予期しないエラーが発生しました。 (ID 104 詳細: 内部エラー コード: 0x80990A51)
種類: テープ バックアップの状態: 失敗した説明: アクセスが拒否されたため、DPM はServer_name.comの保護エージェントと通信できませんでした。 (ID 42 詳細: アクセスが拒否されました (0x80070005))
DPM は ProtectedServer.Contoso.local 上の保護エージェント サービスと通信できませんでした。 (ID 308 詳細: RPC サーバーが使用できません (0x800706BA))
DPM が protected.server.contoso.com の保護エージェント サービスと通信できなかったため、保護エージェントの操作が失敗しました。 (ID 308 詳細: RPC サーバーが使用できません (0x800706BA))
種類: 復旧ポイントの状態: 失敗した説明: Server_name.comの保護エージェントは、予期しない状態であったため、一時的に応答できませんでした。 (ID 60 詳細: 内部エラー コード: 0x809909B0)
DPM サービスが ProtectedServer.Contoso.local 上の保護エージェントと通信できませんでした。 (ID 52 詳細: 既存の接続がリモート ホストによって強制的に閉じられた (0x80072746))
DPM サービスが ProtectedServer.Contoso.local 上の保護エージェントと通信できませんでした。 (ID 52 詳細: セマフォ タイムアウト期間が切れています (0x80070079))
エージェントが応答していないため、DPM は ProtectedServer.Contoso.local 上の保護エージェントと通信できませんでした。 (ID 43 詳細: 内部エラー コード: 0x8099090E)
コンピューターに到達できないため、DPM が ProtectedServer.Contoso.local と通信できませんでした。 (ID 41 詳細: ターゲット マシンがアクティブに拒否したため、接続できませんでした (0x8007274D))
原因
この問題は、ネットワークで待機時間が長い場合、またはネットワークがデータ転送で飽和状態になっている場合に発生します。 これらの条件が満たされると、DCOM トラフィックが遅延します。 これにより、エージェントが断続的にタイムアウトします。
回避策
この問題を回避するには、次の手順に従って、DPM サーバーと保護されたサーバーにいくつかのレジストリ エントリを追加します。
メモ帳で、次のエントリをファイルに貼り付け、 ファイルをDPMAgentTimeout.regとして保存します。
Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent] "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20 "ConnectionNoActivityTimeout"=dword:00001c20 "AbortAgentOnLockTimeout"=dword:00000001 "CommandTimeout"=dword:1b7740 [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters] "TcpMaxDataRetransmissions"=dword:00000010
DPMAgentTimeout.reg ファイルを右クリックし、[マージ] を選択します。
変更を有効にするには、DPMRA サービスまたはサーバーを再起動します。
問題が解決しない場合は、85 ~ 90% の DPM 調整を有効にして、DCOM 呼び出しで帯域幅を使用できることを確認します。 [管理] タブの [エージェント] タブで、保護されている各サーバーの帯域幅調整を有効にすることができます。
値の TcpMaxDataRetransmissions
詳細については、「 TCP/IP の最大再送信タイムアウトを変更する方法」を参照してください。さらに、 DPM サーバーでウイルス対策ソフトウェアを実行します。
詳細
DPM サーバーと保護されたサーバーの間で渡されるコントロールとデータ情報には、さまざまなチャネルがあります。 制御パスは DCOM (RPC) チャネルを使用し、データ パスは TCP/IP を使用します。 データ パスが (短時間でも) ネットワークを完全に飽和状態にした場合、DCOM 呼び出しが失敗する可能性があります。 呼び出しが失敗すると、ジョブが失敗します。 この問題を回避するには、保護されたサーバーの調整を有効にして、データ パスのネットワーク使用量を 85% に制限します。
調整では、DPM サーバーと保護されたサーバーの両方にサービス品質 (QoS) をインストールする必要があるため、既定では、調整は DPM では有効になっていません。
85% の設定で問題が完全に解決されない場合は、問題がある保護されたサーバーの調整レベルを上げます。
この解決策で問題が解決しない場合は、DPM サーバーが過負荷である可能性があります。 バックアップがずれているように保護グループを再構成するか、同期が時間差で発生するようにしてください。
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