A computer that is running Windows XP SP3 cannot authenticate a wireless router that uses the Wi-Fi Protected Setup (WPS) when the router is configured to use Wired Equivalent Privacy (WEP)

Article translations Article translations
Article ID: 971455 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

Consider the following scenario. You try to configure the security setting on a computer that is running Windows XP Service Pack 3 (SP3) by using the Wi-Fi Protected Setup (WPS) technology. In this scenario, the computer cannot authenticate the WPS router because the router is configured to use Wired Equivalent Privacy (WEP).

Cause

This problem occurs because Windows XP SP3 mistakenly tries to authenticate a WEP-configured device by using 802.1X authentication. Therefore, the authentication fails.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 3 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wzcdlg.dll5.1.2600.5815383,48819-May-200921:48x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

For more information about devices that use Wi-Fi Protected Setup or Windows Connect Now, click the Wi-Fi Protected Setup link on the following Web site:
http://www.wi-fi.org/knowledge_center_overview.php
For more information about how to use the Wireless Network Setup Wizard, visit the following Web site:
http://technet.microsoft.com/en-us/library/bb878069.aspx

Properties

Article ID: 971455 - Last Review: March 8, 2013 - Revision: 3.0
Applies to
  • Microsoft Windows XP Service Pack 3, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe KB971455

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com