Un certificado. p7b no importa correctamente al intentar importarlo mediante el Asistente para importación de certificados en MMC en un equipo que ejecuta Windows Server 2008 o Windows Vista

Seleccione idioma Seleccione idioma
Id. de artículo: 971510 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

En un equipo que ejecuta Windows Server 2008 o Windows Vista, intente importar el certificado de formato. p7b mediante el Asistente para importación de certificados en Microsoft Management Console (MMC). Sin embargo, el certificado no se importa correctamente. Cuando se produce este problema, puede experimentar los síntomas siguientes:
  • El certificado importado no tiene una clave privada asociada con él.
  • El objeto de solicitud de certificado en la solicitud de certificado del almacén permanece.
  • El Asistente para importación de certificados completa sin mostrar ningún error.

Causa

Este problema se produce porque. p7b formato certificados no se descodifican correctamente al importar certificados de formato. p7b desde el Asistente para importación de certificados en MMC.

Solución

Para resolver este problema, importe el certificado mediante el comando certreq - Aceptar en lugar de utilizar al Asistente para importación de certificados en MMC.

Ejemplo:
certreq - acepte Certificate.p7b

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 971510 - Última revisión: martes, 21 de julio de 2009 - Versión: 2.1
La información de este artículo se refiere a:
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008 R2
  • Windows Web Server 2008
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palabras clave: 
kbmt kbtshoot kbexpertiseinter KB971510 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 971510

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com