Nelze nainstalovat Instalační služba Windows Installer, aktualizovat balíček v kontextu místního systému v počítači se systémem Windows XP, který má nainstalovanou KB956572

Překlady článku Překlady článku
ID článku: 971913 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • V počítači se systémem Windows XP Service Pack 3 (SP3) máte MS09-012 aktualizace popsané v článku znalostní báze Microsoft Knowledge Base (KB) 956572 nainstalován.
  • Vytvoření zásad omezení softwaru, které neumožňuje instalaci určitých balíčku MSI (Instalační služba Windows Installer).
  • Pokusíte se nainstalovat tento balíček MSI v kontextu místního systému.
Poznámka: Můžete naplánovat instalaci balíčku MSI v kontextu místního systému pomocí na příkaz.

V tomto případě nelze nainstalovat balíček MSI a zobrazí se chybová zpráva podobná následující:

Správce systému nastavil zásady zabránit instalaci.
Dále pokud povolíte protokolování MSI, můžete zjistit podobná v protokolu instalace MSI následující záznam:

Podproces MainEngineThread vrací 1625

Příčina

Tento problém je způsoben chybě v aktualizaci popsanou v článku KB 956572. Tato chyba předmět do pravidla zásad omezení softwaru, které by nemělo mít vliv místní systémový účet místní systémový účet.

Řešení

Informace o opravě hotfix

Poznámka: Následující opravy hotfix platí pro balíček Instalační služba Windows Installer 3.1, který je součástí aktualizace Windows XP SP3. Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, odešlete žádost o podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musíte mít v počítači nainstalovaná aktualizace Windows XP SP3.Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
322389Jak získat nejnovější aktualizaci service pack pro systém Windows XP

Požadavek na restartování

Po instalaci této opravy hotfix, je nutné restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo karty v Datum a čas Chcete-li zobrazit položky v Ovládacích panelech.
Systém Windows XP s aktualizací Service Pack 3 pro verze x 86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
MSI.dll3.1.4001.58412,843,13607. Července-200914: 05x 86

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Můžete povolit protokolování pro instalaci spuštěním následujícího příkazu při instalaci balíčku MSI MSI:

msiexec /i Název balíčkuMSI/l * v c:\Název balíčku_logging.log

Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
956572MS09-012: Popis aktualizace zabezpečení pro izolaci služeb systému Windows: duben 2009

Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
310791Popis zásad omezení softwaru v systému Windows XP


Další informace o protokolování normální navštivte následující Web společnosti Microsoft:
http://msdn.microsoft.com/en-us/library/aa370536 (VS.85) .aspx
Další informace o zásadách omezení softwaru naleznete na následujících webech společnosti Microsoft:
http://technet.microsoft.com/en-us/library/cc782792 (WS.10) .aspx
http://technet.microsoft.com/en-us/library/cc782430 (WS.10) .aspx

Vlastnosti

ID článku: 971913 - Poslední aktualizace: 23. května 2011 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
Klíčová slova: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbmt KB971913 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:971913

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com