FIX: You cannot establish a new APPC session after you switch to another CICS region in Host Integration Server 2006

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Article ID: 971915 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario.
  • You are in a Microsoft Host Integration Server 2006 environment. You open a conversation in a dependent Advanced Program-to-Program Communications (APPC) session.
  • You configure the conversation to use a particular Logic Unit (LU) pair that is appropriate for the Customer Information Control System (CICS) region.
  • Then, you switch to a new CICS region. You use the same local LU, but change the remote LU to one appropriate for the new CICS region.
In this scenario, you cannot establish a new APPC session.

CAUSE

This issue occurs because the IP data link connection (IPDLC) link service incorrectly sends an UNBIND code as an UNBIND cleanup code.

At first, the session is unbound in the Normal state with a Request Unit code (0x3201). After you start a new application by specifying a different remote LU, this UNBIND code is converted to an UNBIND cleanup code (0x320F) by the IPDLC link service. The UNBIND cleanup code is sent to the mainframe together with the following sense code:
    08A0
    Session Reset: An LU or PU is resetting an LU-LU session.
    0002
    The LU or session connection manager (SCM) will send UNBIND with a reason code of X'0F' (Cleanup)

RESOLUTION

To resolve this problem, obtain the latest service pack for Host Integration Server 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Host Integration Server 2006 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix Replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain of all the files that you must have to fully update a product to the latest build. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
32-bit (x86) version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Snaipdlc.dll7.0.2926.0990,02417-Jun-200909:48x86
Snaipdlc.pdbNot applicable764,92817-Jun-200909:48Not applicable
Trcipdlc.dll7.0.2926.02,960,20017-Jun-200909:48x86
Trcipdlc.pdbNot applicable3,116,03217-Jun-200909:48Not applicable
64-bit (x64) version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Snaipdlc.dll7.0.2926.01,461,57617-Jun-200909:50x64
Snaipdlc.pdbNot applicable805,88817-Jun-200909:50Not applicable
Trcipdlc.dll7.0.2926.03,952,45617-Jun-200909:50x64
Trcipdlc.pdbNot applicable3,378,17617-Jun-200909:50Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about APPC, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/aa746031(BTS.10).aspx


For more information about CICS, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/aa746031(BTS.10).aspx

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 971915 - Last Review: October 7, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB971915

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