Error message when you add a user to Microsoft Dynamics CRM 4.0 from a trusted parent domain: "You are attempting to create a user with a domain logon that does not exist. Select another domain logon and try again"

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Article ID: 972033 - View products that this article applies to.
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SYMPTOMS

When you try to add a user to Microsoft Dynamics CRM 4.0 from a trusted parent domain, you receive the following error message:
You are attempting to create a user with a domain logon that does not exist. Select another domain logon and try again.
Additionally, an error message that resembles the following is logged in the Microsoft Dynamics CRM platform tracing log:
>Unable to get DNS name of domain <parent domain name>: System.Net.Sockets.SocketException: No such host is known
> at System.Net.Dns.GetAddrInfo(String name)
> at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
> at System.Net.Dns.GetHostEntry(String hostNameOrAddress)
This problem occurs if Microsoft Dynamics CRM is in a child domain that does not have the global catalog (GC).

CAUSE

This problem occurs because Microsoft Dynamics CRM is in a child domain that does not have the GC.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

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Article ID: 972033 - Last Review: August 27, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB972033

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