Article ID: 972402 - Last Review: July 29, 2009 - Revision: 1.2

The Attendant Console does not correctly process incoming voice calls if the Microsoft Office Communications Server 2007 R2 Attendant is configured to start automatically in General Options

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SYMPTOMS

The Microsoft Office Communications Server 2007 R2 Attendant is configured to start automatically in General Options. In this situation, Microsoft Office Communicator 2007 R2 starts and runs successfully. However, the Attendant Console does not correctly process incoming voice calls.

CAUSE

This problem occurs when Office Communications Server 2007 R2 Attendant and Office Communicator 2007 R2 both run at the same time. Each client process is expected to create a mutex in memory. When the mutex from the first process is detected, this is expected to force the second client process to close during startup. If Microsoft Office Communications Server 2007 R2 Attendant is configured to start automatically in General Options, a mutex is not created. This enables Microsoft Office Communicator 2007 R2 to run at the same time.

If Microsoft Office Communications Server 2007 R2 Attendant is configured to start automatically in General Options, a mutex is not created. This enables Microsoft Office Communicator 2007 R2 to run at the same time.

WORKAROUND

To work around this issue, do not configure Microsoft Office Communications Server 2007 R2 Attendant to start automatically in General Options. Start the program manually, or copy a shortcut to Attendant into the Startup folder.

Note The Startup folder is located under Programs on the Start menu.

RESOLUTION

To resolve this issue, install the following update:

970275  (http://support.microsoft.com/kb/970275/ ) Description of the update package for Communications Server 2007 R2, Attendant: June 2009

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Office Communications Server 2007 R2 Standard Edition
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
Keywords: 
kbfix kbqfe kbexpertiseinter kbsurveynew kbprb KB972402
 

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