Error message when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC: "The search filter is invalid"

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Article ID: 972426 - View products that this article applies to.
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SYMPTOMS

In a Microsoft Exchange Server 2007 environment, when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC, you receive a "The search filter is invalid" error message. Additionally, the default filter does not work. Therefore, you have to remove and then re-create the default filter.

The following is an example of the error message that you receive:
Active Directory Operation failed on <domain controller>. This error is not retriable. Active Directory Response: The search filter is invalid. It was running command “get-recipient –resultsize ‘1000’ –sortby “displayname” – RecipientType ‘usermailbox’ –filter “{serverlegacydn –eq””}“

CAUSE

The filter is saved with the incorrect syntax.

RESOLUTION

To resolve this problem, install the following update rollup:
971534 Description of Update Rollup 1 for Exchange Server 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 972426 - Last Review: November 19, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbsurveynew kbexpertiseinter kbfix kbhotfixrollup kbqfe KB972426

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