╚ possibile utilizzare il comando "runas" per stampare da diversi account utente in un'unica sessione da un programma a 32 bit su un computer che esegue la versione a 64 bit di Windows Server 2008 o Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 972616 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer che esegue una versione a 64 bit di Windows, Ŕ possibile utilizzare il comando runas per stampare da un programma a 32 bit da diversi account utente in una singola sessione.

Cause

Questo comportamento si verifica perchÚ il sistema utilizza il processo di Splwow64.exe la conversione tra i programmi a 32 bit e il modello di driver del sistema operativo a 64 bit. Un processo di stampa al termine di un account utente, il processo di Splwow64.exe rimane in memoria per un periodo di tempo per aumentare le prestazioni del sistema. Tuttavia, il processo di Splwow64 non termina come previsto. Pertanto, quando si utilizza il comando runas per avviare un programma a 32 bit, non Ŕ possibile stampare da diversi account utente.

Risoluzione

Per Windows Server 2003 a 64 bit, tutte le versioni

Nessun hotfix Ŕ disponibile per questo problema.

Per ulteriori informazioni sul problema analogo in Windows Server 2003, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
923357 ╚ possibile utilizzare il comando RUNAS per stampare da un programma a 32 bit in diversi account utente in una singola sessione in un computer che esegue una versione a 64 bit di Microsoft Windows

Per Windows Server 2008 e Windows Vista versioni a 64 bit

Un hotfix Ŕ disponibile per risolvere il problema. Questo hotfix consente di impostare il valore di timeout predefinito per il periodo in cui il processo di Splwow64.exe rimane in memoria. Questo valore predefinito Ŕ di due minuti. Di conseguenza, il processo di Splwow64.exe viene arrestato due minuti dopo la chiusura dell'ultimo processo di stampa in un account utente. ╚ inoltre possibile configurare questo valore di timeout modificando il valore del Registro di sistema nella seguente sezione "Informazioni del Registro di sistema".

Per Windows Server 2008 R2 e Windows 7 nelle versioni a 64 bit

Quando si stampa da pi¨ applicazioni a 32 bit in esecuzione in account utente diversi all'interno di una sessione, eseguire pi¨ istanze di Splwow64.exe in ciascun account utente per l'applicazione. Ci˛ significa che un'istanza di Splwow64.exe funziona in modo indipendente e non interferisce con altre istanze in esecuzione. Questo processo evita la limitazione di un solo utente la possibilitÓ di stampare da una singola sessione.

Informazioni sull'hotfix

Un hotfix supportato Ŕ disponibile da Microsoft. Tuttavia, questo hotfix Ŕ destinato a correggere il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix vengano eseguiti ulteriori test. Se il problema non causa gravi difficoltÓ, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix Ŕ disponibile per il download, Ŕ presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se Ŕ necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto usuali verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo di numeri di telefono di assistenza clienti Microsoft o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'hotfix. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido non Ŕ disponibile per tale lingua.


Importanti aggiornamenti rapidi di Windows Vista e Windows Server 2008 sono inclusi nel pacchetto stesso. Tuttavia, solo uno di questi prodotti pu˛ essere elencato nella pagina "Richiesta di aggiornamento rapido". Per richiedere il pacchetto di hotfix che si applica a Windows Vista e Windows Server 2008, Ŕ sufficiente selezionare il prodotto elencato nella pagina.

Prerequisiti

Per applicare questo hotfix, il computer deve eseguire uno dei seguenti sistemi operativi:
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Vista Service Pack 2 (SP2)
  • Windows Vista Service Pack 1

Richiesta di riavvio

Non Ŕ necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni del Registro di sistema

Per configurare il valore di timeout, attenersi alla seguente procedura.

Importante Questa sezione, metodo o attivitÓ contiene viene illustrato come modificare il Registro di sistema. Tuttavia, pu˛ causare seri problemi se si modifica il Registro di sistema in modo non corretto. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, Ŕ possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
Articolo 322756 Come eseguire il backup e ripristino del Registro di sistema Windows
  1. Fare clic su Avviare, quindi fare clic su Eseguire.
  2. Tipo Regedit , quindi fare clic su OK.
  3. Individuare e quindi fare doppio clic sulla seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
  4. Scegliere Nuovo, quindi fare clic su Valore DWORD.
  5. Tipo SplWOW64TimeOutSecondscome nome della voce del Registro di sistema e quindi premere INVIO.
  6. Fare doppio clic su di SplWOW64TimeOutSeconds voce creata nel passaggio 4.
  7. Immettere un valore di Dati valore casella e quindi scegliere OK.
Nota╚ necessario immettere un valore maggiore di 0 (zero) ilDati valore casella. Il valore immesso Ŕ il numero di secondi che il sistema attende periodicamente mentre il sistema controlla se il processo di Splwow64.exe deve essere scaricato. Il processo di Splwow64.exe viene scaricato quando Ŕ trascorso il numero di secondi specificato in SplWOW64TimeOutSeconds poichÚ il processo di stampa a 32 bit ultimo chiuso. Pertanto, quando viene stampato un processo di servizio, la possibilitÓ di stampa non viene rilasciata fino a quando il servizio viene chiuso e al minimo il tempo specificato nel Dati valore casella passa. Ad esempio, se si digita 15 nel Dati valore casella e l'ultimo processo a 32 bit richiede due minuti per stampare e Chiudi, viene rilasciata la funzionalitÓ di stampa tra due minuti e 15 secondi e due minuti e 30 secondi. Se non viene specificato alcun valore di timeout, il valore di timeout predefinito Ŕ due minuti.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate nel tempo universale coordinato (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per trovare la differenza tra ora UTC e ora locale, utilizzare il Fuso orario scheda di Data e ora elemento nel Pannello di controllo.

Per tutte le versioni basate su x64 di Windows Server 2008 e Windows Vista

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione fileDimensione fileDataOraPiattaforma
Splwow64.exe6.0.6001.2246439.93607-Lug-200916: 27x64
Splwow64.exe6.0.6002.2216539.93607-Lug-200916: 01x64

Per tutte le versioni basate su Itanium di Windows Server 2008

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione fileDimensione fileDataOraPiattaforma
Splwow64.exe6.0.6001.2246484,48007-Lug-200916: 53IA-64
Splwow64.exe6.0.6002.2216584,48007-Lug-200916: 00IA-64

Workaround

Per aggirare questo problema, utilizzare uno dei metodi descritti di seguito.

Soluzione alternativa 1

Non utilizzare il comando runas per la stampa.

Soluzione 2

Prima di utilizzare il comando runas per stampare da un programma a 32 bit in diversi account utente in una singola sessione, terminare il processo di Splwow64.exe.

Status

Microsoft ha confermato che questo Ŕ un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Informazioni

In un computer che esegue una versione a 64 bit di Microsoft Windows, un solo account utente pu˛ stampare da un programma a 32 bit in una singola sessione. In un'unica sessione, l'account utente che viene stampato prima Ŕ l'unico account utente in cui poter stampare un processo a 32 bit, fino a quando non si verifica un timeout o termina la sessione. Se un altro account utente nella stessa sessione tenta di stampare prima della fine della sessione, l'account utente riceve un messaggio di errore "Handle non valido". Inoltre, la richiesta di stampa viene completata.

Pi¨ di un processo pu˛ eseguire in account utente diversi nella stessa sessione. Negli esempi seguenti:
  • Processi di servizio che vengono eseguiti nella stessa sessione. Tuttavia, gli account utente che esegue i processi di servizio sono determinati dalle impostazioni del servizio.
  • I processi che vengono avviati mediante il runas comando.

Per ulteriori informazioni, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 972616 - Ultima modifica: lunedý 6 agosto 2012 - Revisione: 10.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
Chiavi:á
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver kbmt KB972616 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 972616
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com