"Runas"コマンドを使用すると、別のユーザー アカウントを 1 つのセッションからは、32 ビット プログラムを 64 ビット版の Windows Server 2008 または Windows Vista を実行しているコンピューター上で印刷できません。

文書翻訳 文書翻訳
文書番号: 972616 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

64 ビット バージョンの Windows を実行しているコンピューターでは、1 つのセッションで 32 ビット プログラム別のユーザー アカウントからからを印刷するには、 runasコマンドを使用できません。

原因

この現象は、 Splwow64.exeプロセスのシステムで 32 ビット プログラムと 64 ビットのオペレーティング システムのドライバー モデル間の変換に使用するために発生します。ユーザー アカウントで印刷ジョブが完了したら、Splwow64.exe プロセス メモリにシステムのパフォーマンス向上のために時間が保持されます。しかし、 Splwow64のプロセスが正常に終了しません。したがって、32 ビット プログラムを起動するのには、 runasコマンドを使用すると、別のユーザー アカウントからは印刷できません。

解決方法

Windows Server 2003 では、64 ビットのすべてのバージョン

この問題に対する修正プログラムはありません。

Windows Server 2003 上で同様の問題の詳細については、「サポート技術情報」資料を参照するには、次の資料番号をクリックしてください。
923357 RUNAS コマンドを使用すると、32 ビット プログラムで別のユーザー アカウントから 1 つのセッションでは、64 ビット バージョンの Microsoft Windows を実行しているコンピューター上で印刷することはできません。

Windows Server 2008 と Windows Vista の 64 ビット バージョン

この問題を解決するされています。この修正プログラムでは、Splwow64.exe プロセス メモリに残ります期間のデフォルトのタイムアウト値を設定します。この既定値は 2 分です。したがって、Splwow64.exe プロセスは 1 つのユーザー アカウントでの最後のプリント ジョブを閉じた後 2 分間ダウンをシャット ダウンします。さらに、「レジストリ情報」セクション下のレジストリ値を変更して、このタイムアウト値を構成できます。

Windows Server 2008 R2 および Windows 7 の 64 ビット バージョン

内の別のユーザー アカウントを 1 つのセッション内で実行する複数の 32 ビット アプリケーションから印刷すると、各アプリケーション用のユーザー アカウントで、Splwow64.exe の複数のインスタンスを実行します。つまり、Splwow64.exe のインスタンスは関係なく機能し、他の実行中インスタンスには影響はありません。これは、1 つのセッションから印刷できることは 1 つだけのユーザーの制限を克服しています。

修正プログラムの情報

サポートされている修正プログラムをマイクロソフトから入手することができます。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの資料に記載されている問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストがあります。したがって、この問題のために深刻な影響を受けていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

修正プログラムがダウンロード可能な場合は、この記事の上部に「修正プログラムのダウンロード」セクションが表示されます。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポートへお問い合わせいただき、修正プログラムを入手してください。

その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス & サポートの電話番号の一覧または別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
「修正プログラムのダウンロード」フォームには、利用可能な言語の修正プログラムが表示されます。お使いの言語の修正プログラムが存在しない場合、表示されません。


重要な Windows Vista と Windows Server 2008 の修正プログラムは、同じパッケージに含まれています。ただし、これらの製品は 1 つだけ、「修正プログラムの要求」ページに表示されます。Windows Vista と Windows Server 2008 の両方に適用される修正プログラム パッケージを要求するには、ページに記載されている製品を選択します。

前提条件

この修正プログラムを適用するには、コンピューター、次のオペレーティング システムのいずれかの実行する必要があります。
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Vista のサービス パック 2(SP2)
  • Windows Vista のサービス パック 1(SP1)

再起動の必要性

この修正プログラムの適用後、コンピューターを再起動する必要はありません。

レジストリ情報

タイムアウト値を構成するには、次の手順を実行します。

重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリのバックアップ方法および復元方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
  1. クリックしてください。 ボタンをクリックし、、をクリックして、 Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない.
  2. 種類 をクリックし、 プロパティ ].
  3. 見つけて、次のレジストリ サブキーを右クリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
  4. ポイントします。 新しいプロパティ DWORD 値.
  5. 種類 SplWOW64TimeOutSecondsレジストリ エントリの名前、Enter キーを押します。
  6. ダブルクリックして、 SplWOW64TimeOutSeconds 手順 4 で作成したエントリを指定します。
  7. 値を入力して、 [値のデータ [ ].
0 (ゼロ) より大きい値を入力する必要があります、[値のデータ ボックス。入力値は、システム、Splwow64.exe プロセスがアンロードする必要があるかどうかを確認して、システムを定期的に待機する秒数です。最後の 32 ビットの印刷プロセスを終了するために SplWOW64TimeOutSeconds で指定された秒数が経過したら、Splwow64.exe プロセスに読み込まれていません。サービスのプロセスを表示すると、そのため、印刷機能で、サービスを終了するまで解放されませんで設定した最低限の時間、 [値のデータ ボックスを渡します。たとえばと入力すると、 15 続いて [値のデータ ボックスし、最後の 32 ビット プロセスが 2 分を印刷し、印刷機能 2 分 15 秒 〜 2 分 30 秒を閉じる、解放されます。タイムアウト値が指定されていない場合は、デフォルトのタイムアウト値は 2 分です。

ファイル情報

この修正プログラムの英語版のファイル属性 (またはそれ以降のファイル属性) を、次の表に一覧表示します。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイルの情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン で、 日付と時刻 コントロール パネルの項目。

サポートされているすべての Windows サーバー 2008年と Windows Vista の x64 ベース バージョン x

元に戻す全体を表示する
ファイル名のプロパティを確認します。ファイルのサイズ日付時間プラットフォーム
Splwow64.exe6.0.6001.2246439,93607-7 月-200916: 27x 64
Splwow64.exe6.0.6002.2216539,93607-7 月-200916: 01x 64

サポートされているすべての Itanium ベース バージョンの Windows Server 2008 の

元に戻す全体を表示する
ファイル名のプロパティを確認します。ファイルのサイズ日付時間プラットフォーム
Splwow64.exe6.0.6001.2246484,48007-7 月-200916: 53IA 64
Splwow64.exe6.0.6002.2216584,48007-7 月-200916: 00IA 64

回避策

この問題を回避するには、次の方法のいずれかを使用します。

回避策 1

印刷するには、 runasコマンドを使用しないでください。

回避策 2

1 つのセッションでは、32 ビット プログラムで別のユーザー アカウントからを印刷するには、 runasコマンドを使用する前に、Splwow64.exe プロセスを終了します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

64 ビット バージョンの Microsoft Windows を実行しているコンピューターでは、1 つだけのユーザー アカウントで 32 ビット プログラムから 1 つのセッションで印刷可能性があります。印刷されるユーザー アカウントは 1 つのセッションでは、タイムアウトになったか、セッションが終了するまで、32 ビット プロセスを印刷できる唯一のユーザー アカウント最初です。ユーザー アカウントは、セッションが終了する前に印刷するには、同じセッションで別のユーザー アカウントをしようとする場合は、「ハンドルが無効です」エラー メッセージを受け取ります。また、印刷要求は受け入れられません。

1 つ以上のプロセスと同じセッションで別のユーザー アカウントを実行できます。例は次のとおりです。
  • サービスと同じセッションでの実行を処理します。ただし、サービスのプロセスを実行するユーザー アカウントをサービスの設定によって決まります。
  • 使用して開始されるプロセスは runas コマンドです。

詳細については、「サポート技術情報」資料を参照するには、次の資料番号をクリックしてください。
824684 マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明

プロパティ

文書番号: 972616 - 最終更新日: 2012年8月6日 - リビジョン: 11.0
この資料は以下の製品について記述したものです。
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
キーワード:?
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver kbmt KB972616 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:972616
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com