Pokud hledání instance pomocí ovládacího prvku zobrazení virtuálního seznamu LDAP, může být poškozena indexu aplikace Active adresářové

Překlady článku Překlady článku
ID článku: 972622 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme následující situaci:
  • Aktivní adresářové aplikace nainstalované v počítači se systémem Windows Server 2003 Service Pack 2 (SP2).
  • Aplikace nebo služba prohledává instance aplikace Active adresářové pomocí ovládacího prvku zobrazení virtuálního seznamu pro LDAP (Lightweight Directory Access Protocol).
V tomto scénáři může dojít k poškození instance Active adresářové aplikace a aplikace nebo služba může dojít k selhání hledání. Máte proveďte offline defragmentaci zrušte poškozené indexu.

Když nastane tento problém je zaznamenána následující událost v protokolu událostí aplikací Active adresářové instance:

Typ události: Chyba
ADAM zdroj události: <name > ISAM
Kategorie události: Poškození databáze
ID události: 467
Date: <date>
Time: <time>
Uživatel: N/A
Počítač: <computer name >
Popis: <name > (1912) ADAMDSA: index INDEX_S_00000003 datové tabulky tabulky je poškozen (0).

Příčina

K tomuto problému dochází, protože instance databázový stroj aplikace Active adresářové nespravuje aktualizace indexu správně při indexu n-tice má více než jeden sloupec klíče. Toto chování způsobuje poškození indexu.

Řešení

Tato oprava hotfix zabraňuje budoucí výskyt poškození indexu. Index Active adresářové aplikace je poškozen z důvodu tohoto problému, musíte nejprve provést defragmentaci v režimu offline vyřešit poškození. Potom je třeba nainstalovat tuto opravu hotfix zabránit budoucí výskyt poškození indexu.

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí být v počítači Windows Server 2003 Service Pack 2 (SP2).

Další informace o instalaci aktualizace Windows Server 2003 service pack klepněte na následující číslo článku databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003

Požadavek na restartování

Po instalaci této opravy hotfix není třeba počítač restartovat.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné jiné opravy hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi UTC a místním časem, použití kartu časové pásmo v datum a čas v ovládacím panelu.
Pro všechny podporované verze 86 Windows Server 2003 SP2 x

Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Esent.R2.dll1.1.3790.45631,007,61631. Července 200916: 00X86
Pro všechny podporované verze 64 Windows Server 2003 SP2 x

Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Esent.R2.dll1.1.3790.45632,066,43201 VIII 200905: 21X64

Jak potíže obejít

Problém vyřešit, proveďte offline defragmentaci poškozené instance aplikace Active adresářové. Chcete-li to provést, můžete odkaz kroků v následujícím článku znalostní báze Knowledge Base:

232122Provedení offline defragmentace databáze Active Directory (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)


Poznámka: K tomuto problému dochází při každém instance aplikace Active adresářové je poškozen. Doporučujeme nainstalovat tuto opravu hotfix úplně vyřešit problém.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Odkazy

Další informace o vyhledávání pomocí ovládacího prvku zobrazení virtuálního seznamu LDAP naleznete na následujícím webu:
http://msdn.microsoft.com/en-us/library/aa367018(VS.85).aspx
Další informace o vyhledávání pomocí Vyhledávací příznaky atributu naleznete na následujícím webu:
http://msdn.microsoft.com/en-us/library/ms679765(VS.85).aspx

Vlastnosti

ID článku: 972622 - Poslední aktualizace: 30. října 2009 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003 Service Pack 2 na těchto platformách
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB972622 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:972622

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com