LDAP 가상 목록 뷰 컨트롤을 사용하여 인스턴스를 검색할 경우 Active Directory 응용 프로그램 모드 인덱스 손상될 수 있다

기술 자료 번역 기술 자료 번역
기술 자료: 972622 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

영문자와 숫자가 조합된 PIN 코드가 설정된 Bluetooth 장치가 있다면:
  • 활성 디렉터리 응용 프로그램 모드 Windows Server 2003 서비스 팩 2 (SP2)를 실행하는 컴퓨터에 설치됩니다.
  • 응용 프로그램 또는 서비스가 경량 LDAP) 디렉터리 액세스 프로토콜 (에 대한 가상 목록 뷰 컨트롤을 사용하여 Active Directory 응용 프로그램 모드 인스턴스를 검색합니다.
이 시나리오에서는 Active Directory 응용 프로그램 모드 인스턴스 손상되어 응용 프로그램 또는 서비스 검색 오류가 발생할 수 있습니다. 손상된 인덱스 선택을 오프라인 조각 모음을 수행해야 합니다.

이 문제가 발생하면 Active Directory 응용 프로그램 모드 인스턴스 이벤트 로그에 다음 이벤트가 기록됩니다.

이벤트 종류: 오류
이벤트 원본: ADAM <name > ISAM
이벤트 범주: 데이터베이스 손상
이벤트 ID: 467이
Date: <date>
Time: <time>
사용자: N/A
컴퓨터: <computer name >
설명: <name > (1912년) ADAMDSA: 인덱스 INDEX_S_00000003 테이블 데이터 테이블 중 손상된 (0) 입니다.

원인

튜플 인덱스 키 열이 여러 개 있을 때 Active Directory 응용 프로그램 모드 인스턴스 데이터베이스 엔진에서 인덱스 업데이트를 올바르게 관리하지 않기 때문에 이 문제가 발생합니다. 이 문제는 인덱스 손상이 발생합니다.

해결 방법

이 핫픽스는 나중에 발견되는 인덱스 손상 방지할 수 있습니다. 이 문제 때문에 Active Directory 응용 프로그램 모드 인덱스가 손상된 경우 손상을 해결하려면 오프라인 조각 모음을 먼저 수행해야 합니다. 그런 다음 나중에 발견되는 인덱스 손상 방지하기 위해 이 핫픽스를 설치해야 합니다.

핫픽스 정보

Microsoft에서 제공하는 핫픽스를 사용할 수 있습니다. 그러나 이 핫픽스는 이 문서에서 설명된 문제만 해결할 수 있습니다. 이 문서에서 설명하는 문제가 발생하는 시스템에만 이 핫픽스를 적용하십시오. 추후에 이 핫픽스를 테스트할 수 있습니다. 따라서 이 문제로 심각하게 영향을 받은 경우를 제외하곤 이 핫픽스가 포함된 다음 소프트웨어 업데이트까지 기다리는 것이 좋습니다.

다운로드할 핫픽스가 있는 경우, 이 기술 자료 문서의 맨 위에 "사용 가능한 핫픽스 다운로드" 링크가 있습니다. 이 링크가 표시되지 않는 경우, Microsoft 고객 지원 서비스에 문의하여 핫픽스를 구할 수 있습니다.

참고 추가적인 문제가 발생할 경우 또는 모든 문제 해결에 필요한 경우 별도의 서비스 요청을 만들어야 할 수도 있습니다. 핫픽스에 적용되지 않는 추가 지원 질문과 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 서비스 지원 전화 번호 전체 목록 또는 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트로 이동하십시오:
http://support.microsoft.com/contactus/?ws=support
참고 "핫픽스 다운로드 가능" 형식에는 핫픽스를 사용할 수 있는 언어가 표시됩니다. 사용자 언어가 표시되지 않으면 해당 언어의 핫픽스를 사용할 수 없습니다 때문입니다.

전제 조건

이 핫픽스를 적용하려면 컴퓨터에 Windows Server 2003 서비스 팩 2 (SP2) 실행해야 합니다.

Windows Server 2003 서비스 팩을 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
889100Windows Server 2003용 최신 서비스 팩을 구하는 방법

재시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)이 있습니다. 이러한 파일의 시간과 날짜는 UTC (협정 세계시) 로 나열됩니다. 파일 정보에서는 현지 시간으로 변환됩니다. UTC 및 현지 시간으로, 사용 차이 날짜 및 시간표준 시간대 탭을 제어판 항목에서.
지원되는 모든 x 86 기반 버전의 Windows Server 2003 SP2를

표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼
Esent.r2.dll1.1.3790.45631,007,6162009-7월-3116: 00x 86
지원되는 모든 x 64 기반 버전의 Windows Server 2003 SP2를

표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼
Esent.r2.dll1.1.3790.45632,066,4322009-01-8월05: 21x 64

해결 과정

이 문제를 해결하려면 손상된 Active Directory 응용 프로그램 모드 인스턴스에서 오프라인 조각 모음을 수행하십시오. 이렇게 하려면 다음 기술 자료 문서 에서 단계를 참조할 수 있습니다.

232122Active Directory 데이터베이스의 오프라인 조각 모음을 수행하면


참고 이 문제는 때마다 Active Directory 응용 프로그램 모드 인스턴스 손상되었습니다. 이 문제를 완전히 해결하려면 이 핫픽스를 설치하는 것이 좋습니다.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열된 Microsoft 제품에서 이 문제를 확인했습니다.

추가 정보

소프트웨어 업데이트 용어에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
824684Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

참조

LDAP 가상 목록 뷰 컨트롤을 사용하여 검색하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 방문하십시오.
http://msdn.microsoft.com/en-us/library/aa367018(VS.85).aspx
검색 Flags 특성을 사용하여 검색 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 방문하십시오.
http://msdn.microsoft.com/en-us/library/ms679765(VS.85).aspx

속성

기술 자료: 972622 - 마지막 검토: 2009년 10월 30일 금요일 - 수정: 1.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Server 2003 Service Pack 2?을(를) 다음과 함께 사용했을 때
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
키워드:?
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB972622 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com