Video is not displayed after you enable Quality of Service (QoS) at the pool level in Communications Server 2007 R2 and you enable QoS on a client computer

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Article ID: 972772 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario.
  • You enable Quality of Service (QoS) at the pool level in Microsoft Office Communications Server 2007 R2.
  • You enable QoS on a client computer.
  • You restart all the services to force media servers such as Audio Video Multipoint Conferencing Unit (AVMCU), Mediation Server, or Conference Auto Attendant (CAA) to apply the changes.
  • You restart the client computer to apply the changes.
  • You make an audio call or a video call by using the AVMCU.
In this scenario, Real-Time Protocol (RTP) packets from the AVMCU or to the client are marked. However, a significant loss occurs in video. This causes no video or frozen video.

CAUSE

This problem is caused by a bug in the code. The code does not set the correct QoS token bucket size.

RESOLUTION

To resolve this issue, apply the following update:
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
969835 Description of the update package for Office Communications Server 2007 R2, Mediation Server: July 2009

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To work around this issue, disable the QoS marking on video on the client and on the server. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\RTC
  3. On the Edit menu, point to New, and then click Key.
  4. In the New Value #1 box, type Transport, and then press the ENTER key.
  5. Right-click the created Transport registry subkey, point to New, and then click DWORD Value.
  6. In the New Value #1 box, type VideoQoSServiceType, and then press the ENTER key.
  7. Right-click the created VideoQoSServiceType registry entry, and then click Modify.
  8. In the Value data box, type 0, and then click OK.
  9. Exit the Registry Editor.

MORE INFORMATION

For more information about how to enable QoS in Communications Server 2007 R2, click the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/dd441192(office.13).aspx

For more information, click the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/aa373702(VS.85).aspx

Properties

Article ID: 972772 - Last Review: July 28, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Standard Edition
Keywords: 
atdownload kbexpertisebeginner kbsurveynew kbprb KB972772

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