Algunas tarjetas inteligentes realizar solicitudes ocasionar problemas de rendimiento

Seleccione idioma Seleccione idioma
Id. de artículo: 972779 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Algunas peticiones en una tarjeta inteligente tardar minutos en completarse cuando se utiliza el controlador de lector de Framework de controlador de modo de usuario (UMDF). Pero la misma operación puede toman sólo segundos para completar cuando utiliza el controlador de Usbccid.sys de modo de núcleo de Windows Vista.

Causa

La USB Smartcard specification requiere que las tarjetas inteligentes debe responder al controlador antes de completa la solicitud larga. La respuesta establece "solicitud de extensión de tiempo". Esto indica al controlador que la solicitud necesita más tiempo. La respuesta devuelve también un multiplicador que indica el número de "Unidad de tiempo" que necesita la tarjeta inteligente. Sin embargo, algunos multipliers.Therefore muy grandes de informe de tarjetas, las solicitudes pueden tardar minutos en completarse.

En el controlador Usbccid.sys anterior, se puede completar la solicitud en mucho menos tiempo. Aunque la solicitud realiza el mismo cálculo para producir el mismo tiempo de espera largo, no se respeta la espera. En su lugar, envía otra solicitud de lectura al lector inmediatamente.

Solución

Importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que hacer una copia de seguridad del registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Para resolver este problema, utilice uno de los métodos siguientes:

Método 1

Agregue la siguiente entrada del registro:
Subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\<Hardware ID>\<Instance ID>\Device Parameters\WUDFUsbccidDriver
Value: DeviceFlags Type: REG_DWORD Data: 4

Método 2

Agregue la siguiente entrada del registro:
Subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\<Hardware ID>\<Instance ID>\Device Parameters\WUDFUsbccidDriver
Value: WaitThreshold Type: REG_DWORD Data: 1000
nota
  • El valor WaitThreshold se especifica en la unidad de milisegundos. Establezca el valor 1000 para 1 segundo o algún otro valor de umbral inferior a 10 segundos. Si el tiempo de espera calculado es mayor o igual a este valor, el controlador del lector UMDF se omita el tiempo de espera y envíe otra solicitud al lector inmediatamente.
  • La WaitThreshold valor sólo funciona cuando el valor DeviceFlags es ausente o se establece en 0.

Propiedades

Id. de artículo: 972779 - Última revisión: martes, 11 de mayo de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palabras clave: 
kbmt kbtshoot kbexpertiseadvanced kbsurveynew kbprb KB972779 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 972779

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com