O serviço SNMP não responde a todas as solicitações de SNMP em um computador que está executando o Windows Server 2003 depois que as configurações de diretiva de grupo são atualizadas

Traduções deste artigo Traduções deste artigo
ID do artigo: 972840 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • O serviço de protocolo de gerenciamento de rede simples (SNMP) é instalado em um computador que esteja executando o Windows Server 2003 Service Pack 2 (SP2) ou uma versão de 64 x do Windows XP Service Pack 2 (SP2).
  • Você atualizar manualmente as configurações de diretiva de grupo neste computador. Ou, as configurações são atualizadas automaticamente.
Nesse cenário, o serviço SNMP pode não responder às solicitações de SNMP. Você precisa reiniciar o serviço SNMP para recuperar esse problema.

Causa

Durante a diretiva de grupo processo de atualização, algumas chaves do Registro são excluídos e, em seguida, recriados. Se alguns atraso ocorre nesse processo, há um longo período de tempo entre a exclusão de chaves do Registro e a recriação das chaves.

Se uma notificação de alteração da chave do registro é enviada para o serviço SNMP neste período de tempo, o serviço SNMP não pode acessar as chaves do registro esperado. Como o serviço SNMP não tenta novamente para registrar a notificação de alteração do Registro, o serviço SNMP não pode ler essas chaves do registro depois que eles são recriados pelo mecanismo de diretiva de grupo.

O serviço SNMP rejeita todas as solicitações de SNMP porque o serviço não é possível ler alguns valores do registro importante. O serviço SNMP registra tais notificações quando seu serviço é iniciado.

Resolução

Um hotfix está disponível para resolver esse problema. Por padrão, depois de instalar esse hotfix, o SNMP serviço tentativas registrar a notificação de cinco vezes se ele não é possível acessar uma chave do Registro. Você pode personalizar o número de tentativas, criando uma entrada de registro (PolicyNotificationRetries) e defina seu valor como o número de tentativas desejado. Para obter mais informações, consulte a seção "Informações de registro".

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando o Windows Server 2003 Service Pack 2 (SP2) ou uma versão de 64 x do Windows XP Service Pack 2 (SP2). Além disso, o serviço SNMP (Simple Network Management Protocol) deve ser instalado no computador.

Requisitos de reinicialização

Reinicie o computador se o serviço SNMP estiver sendo executado quando esse hotfix está instalado. Se você interromper o serviço SNMP antes de instalar esse hotfix, não é necessário reiniciar o computador.

Informações do registro

Você pode personalizar o número de tentativas criando a seguinte entrada do Registro:
Name: PolicyNotificationRetries
Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters
Type: REG_DWORD
Default value: 5
Observação O valor do item PolicyNotificationRetries indica o número de tentativas. Se você definir o valor como 10, o serviço SNMP tentativas até 10 vezes para registrar a notificação de alteração do Registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para todas as versões com base em 86 x do Windows Server 2003 SP2
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SNMP.exe5.2.3790.454341.47203-Jul-200911: 46x 86
Para todas as versões baseadas em Itanium do Windows Server 2003 SP2
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
SNMP.exe5.2.3790.4543116,73603-Jul-200919: 46IA-64SP2Não aplicável
Wsnmp.exe5.2.3790.454341.47203-Jul-200919: 46x 86SP2UAU
Para todas as versões com base em 64 do Windows Server 2003 SP2 e do Windows XP SP2 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
SNMP.exe5.2.3790.454361.44003-Jul-200919: 46x 64SP2Não aplicável
Wsnmp.exe5.2.3790.454341.47203-Jul-200919: 46x 86SP2UAU

Como Contornar

Para contornar o problema, reinicie o serviço SNMP.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 972840 - Última revisão: terça-feira, 1 de setembro de 2009 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB972840 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 972840

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com