Les applications hébergées par le navigateur WPF (XBAP) peuvent se bloquer lors du démarrage du haut

Traductions disponibles Traductions disponibles
Numéro d'article: 972928 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout
Source : Prise en charge de Microsoft

PUBLICATION RAPIDE

PUBLICATION RAPIDE ARTICLES FOURNISSENT DES INFORMATIONS DIRECTEMENT À PARTIR DE L'ORGANISATION DE SUPPORT MICROSOFT. LES INFORMATIONS CONTENUES DANS CE DOCUMENT SONT CRÉÉES EN RÉPONSE À ÉMERGENTS OU UNIQUE RUBRIQUES, OU EST DESTINÉ À INFORMATIONS AUTRES BASE DE CONNAISSANCES DE SUPPLÉMENT.

Symptôme

Les applications hébergées par le navigateur WPF (XBAP) peuvent se bloquer lors du démarrage du haut.

Cause

Une cause de ce problème est que les inscriptions d'interface au niveau du système sont rompues.

Résolution


Pour que nous puissions résoudre ce problème pour vous, allez à la "Aidez-moi« section. Si vous préférez résoudre le problème vous-même, passez à la "Je résous le problème moi-même« section.

Aidez-moi



Pour résoudre ce problème automatiquement, cliquez sur le Je résous le problème bouton ou un lien. Puis cliquez sur Exécuter dans la Téléchargement de fichier boîte de dialogue zone, puis suivez les étapes de la Je résous le problème Assistant.


Résoudre ce problème
Microsoft Fix it 50811


Notes
  • Cet Assistant peut être en anglais uniquement. Toutefois, la correction automatique fonctionne également pour les autres versions linguistiques de Windows.
  • Si vous n'êtes pas sur l'ordinateur qui rencontre le problème, enregistrez le correctif il solution sur un lecteur flash ou un CD, puis exécutez-le sur l'ordinateur qui rencontre le problème.

Ensuite, accédez à la "Le problème est-il résolu ?« section.



Je résous le problème moi-même


Réenregistrez les interfaces rompues en exécutant les commandes suivantes :

regsvr32 %SystemRoot%\System32\actxprxy.dll
regsvr32 « %ProgramFiles%\Internet Explorer\ieproxy.dll »

Sous Windows 64 bits, également exécuter les commandes suivantes :

regsvr32 %SystemRoot%\SysWOW64\actxprxy.dll
regsvr32 « % ProgramFiles (x 86) %\Internet Explorer\iexplore Explorer\ieproxy.dll »

Sur Windows XP et Windows Server 2003, ces commandes doivent être exécuté à partir d'un compte d'utilisateur avec des privilèges administratifs sur l'ordinateur.

Sous Vista ou version ultérieure, ces commandes doivent être exécutés avec des privilèges élevés. Cliquez sur Démarrer, tous les programmes, Accessoires. Cliquez droit sur invite de commande et choisissez Exécuter en tant qu'administrateur. À l'invite de commandes, exécutez les commandes.

Le problème est-il résolu ?

  • Vérifiez si le problème est résolu. Si le problème est résolu, vous avez terminé avec cette section. Si le problème n'est pas résolu, vous pouvez : Contactez le support technique.
  • Nous aimerions connaître votre opinion. Pour fournir des commentaires ou signaler des problèmes avec cette solution, veuillez laisser un commentaire sur le "Aidez-moi« blog ou envoyez-nous un e-mail message.

Plus d'informations



Une connus cause de ce problème est que les inscriptions d'interface au niveau du système sont rompues. En particulier, les enregistrements pour les interfaces suivantes peuvent être manquants :



· IID_IWebBrowser2

· IID_IShellBrowser



Cela peut être dû à des installations ayant échoué ou les mises à niveau ou les infections par logiciel malveillant.

AVIS DE NON-RESPONSABILITÉ

MICROSOFT ET/OU SES FOURNISSEURS NE FONT AUCUNE DÉCLARATION OU GARANTIE CONCERNANT LA CONFORMITÉ, LA FIABILITÉ OU LA PRÉCISION DES INFORMATIONS CONTENUES DANS LES DOCUMENTS ET GRAPHIQUES ASSOCIÉS PUBLIÉS SUR CE SITE WEB (LES "MATIÈRES") À DES FINS. LES MATÉRIAUX PEUVENT INCLURE DES IMPRÉCISIONS TECHNIQUES OU DES ERREURS TYPOGRAPHIQUES ET PEUVENT ÊTRE RÉVISÉES À TOUT MOMENT SANS PRÉAVIS.

DANS LA MESURE PERMISE PAR LA RÉGLEMENTATION APPLICABLE LOI, MICROSOFT ET/OU SES FOURNISSEURS EXCLUENT ET EXCLURE TOUTES LES REPRÉSENTATIONS, GARANTIES ET CONDITIONS QU'ILS SOIENT EXPRESSE, IMPLICITE OU LÉGALE, Y COMPRIS MAIS NON LIMITÉ AUX REPRÉSENTATIONS, GARANTIES OU CONDITIONS DU TITRE, NON CONTREFAÇON, CONDITION SATISFAISANTE OU QUALITÉ, QUALITÉ MARCHANDE ET ADÉQUATION À UN USAGE PARTICULIER, À LA MATIÈRE.

Propriétés

Numéro d'article: 972928 - Dernière mise à jour: vendredi 6 janvier 2012 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 3.0 Service Pack 1
  • Microsoft .NET Framework 3.0 Service Pack 2
  • Microsoft .NET Framework 3.5
  • Microsoft .NET Framework 3.5 Service Pack 1
Mots-clés : 
kbrapidpub kbnomt kbtshoot kbfixme kbmsifixme kbmt KB972928 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 972928
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com