Un ordinateur multiprocesseur qui exécute Windows Server 2003 SP2 cesse de répondre sous une charge importante si vous modifiez un paramètre du pare-feu Windows

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Numéro d'article: 973295 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Envisagez le scénario suivant :
  • Vous avez un ordinateur multiprocesseur qui exécute Windows Server 2003 Service Pack 2 (SP2).
  • Vous modifiez un ou plusieurs paramètres de pare-feu Windows sur l'ordinateur.
Sous une charge importante, l'ordinateur peut cesser de répondre ou l'ordinateur peut rencontrer un des codes d'erreur Stop suivants :
  • 0X000000C2 BAD_POOL_CALLER
  • 0X000000CC PAGE_FAULT_IN_FREED_SPECIAL_POOL
  • 0X000000D5 DRIVER_PAGE_FAULT_IN_FREED_SPECIAL_POOL

Cause

Ce problème se produit car un problème de synchronisation dans le pare-feu Windows. Ce problème de synchronisation se produit lorsque deux threads essaient de supprimer simultanément la même entrée de mappage. Pour supprimer l'entrée de mappage, un thread devez effectuer deux étapes suivantes :
  1. Le thread définit un indicateur suppression sur cette entrée de mappage.
  2. Le thread supprime l'entrée de mappage.
Dans certaines circonstances, un thread peut supprimer correctement une entrée de mappage pendant un autre thread a terminé l'étape 1. Par conséquent, cette autre thread essaie d'accéder l'espace mémoire libérée lorsqu'il effectue l'étape 2. Ce problème, le système déclenche un code d'erreur Stop ou le comportement peut provoquer le blocage de l'ordinateur.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant le problème décrit dans cet article. Ce correctif va peut-être subir des tests. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contient ce correctif.

Si le correctif est disponible pour téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle de Microsoft et de support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si n'importe quelle résolution des problèmes sont requis, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète de numéros de téléphone Microsoft Services de support technique ou à créer une demande de service distincte, site Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif logiciel, votre ordinateur doit exécuter Windows Server 2003 Service Pack 2 (SP2).

La nécessité de redémarrer

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif n'en remplace aucun autre correctif préalablement publié.

Informations sur les fichiers

La version anglaise de ce correctif dispose les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers figurent en temps universel (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire de l'élément date et heure dans le Panneau de configuration.
Pour toutes les x versions 86 de Windows Server 2003 SP2
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipnat.sys5.2.3790.4554119,80817-Juil-200912 : 20x 86
Pour toutes les versions Itanium de Windows Server 2003 SP2 prises en charge
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipnat.sys5.2.3790.4554384,00018-07-200903 : 56IA-64
Pour toutes les versions 64 de Windows Server 2003 SP2 et Windows XP SP2 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ipnat.sys5.2.3790.4554181,24818-07-200903 : 56x 64

Statut

Microsoft a confirmé le que de ce problème dans les produits Microsoft répertoriés dans la section «S'applique à».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 973295 - Dernière mise à jour: jeudi 13 août 2009 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Mots-clés : 
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Traduction automatique
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La version anglaise de cet article est la suivante: 973295
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