A member server may stop responding if the Application Experience Lookup Service service runs on a member server that is running Windows Server 2003 SP2 or an x64-based version of Windows XP SP2

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Article ID: 973570 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • In a domain environment, you have a member server that is running Windows Server 2003 Service Pack (SP2) or an x64-based version of Windows XP Service Pack (SP2).
  • This member server runs the Application Experience Lookup Service service.
Randomly, the users in the domain encounter one or more of the following issues:
  • Users cannot log on to the domain from their client computers, and they receive the "RPC service is unavailable" error message.
  • Users cannot access the shared folders on the member server.
  • Users cannot start an application or service.
  • The server stops responding.

CAUSE

This issue occurs because of a dead lock between the Lightweight Directory Access Protocol (LDAP) client and the Application Experience Lookup Service service.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2003 Service Pack 2 (SP2)
  • An x64-based version of Windows XP Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you install this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Authz.dll5.2.3790.455171,68014-Jul-200917:30x86
For all supported x64-based versions of Windows Server 2003 and of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Authz.dll5.2.3790.4551175,61614-Jul-200915:13x64SP2Not Applicable
Wauthz.dll5.2.3790.455171,68014-Jul-200915:13x86SP2WOW
For all supported Itanium-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Authz.dll5.2.3790.4551237,56814-Jul-200915:12IA-64SP2Not Applicable
Wauthz.dll5.2.3790.455171,68014-Jul-200915:12x86SP2WOW

WORKAROUND

To work around this issue, stop the Application Experience Lookup Service service.

Note After the Application Experience Lookup Service service is stopped, the dead lock is avoided. However, the heap corruption exception may still cause other function failures.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 973570 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB973570

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