The Language Monitor and bidirectional support settings are not migrated for some devices after you upgrade to Windows 7

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Article ID: 973649 - View products that this article applies to.
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SYMPTOMS

You upgrade a computer from Windows Vista to Windows 7. The computer had a standard or multifunction printer installed that supports bidirectional printing installed. However, after the upgrade you notice the Enable bidirectional support option is disabled even though this option was enabled before the upgrade.

Additionally, you may receive an error message that resembles the following when you try to print:
Cannot communicate with the printer. Enable bidirectional support on in the printer's Properties dialog box.

CAUSE

This issue occurs because the language monitor and the bidirectional support settings are not migrated for some devices when you upgrade to Windows 7.

RESOLUTION

To resolve this issue, use one or more of the following methods.

Method 1: Enable bidirectional support (Recommended)

To enable bidirectional support in Windows 7, first restart the computer, and then follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type printer in the Start Search box, and then click Devices and Printers in the Control Panel list.
  2. Right-click the printer, and then click Properties.
  3. Click the Ports tab, click to select the Enable bidirectional support check box, and then click OK.
  4. Close the Printers dialog box.
  5. Restart the computer.
Note Method 1 works in most cases. If enabling bidirectional support for your device does not resolve the issue, go to method 2.

Method 2: Uninstall and then reinstall the drivers for your device

If method 1 does not resolve the issue, you will have to uninstall the drivers for your device and then install the latest drivers. To do this, use one of the following methods:
  • Use the hardware uninstall program if one was included in the installation. The uninstall program is typically located in the All Programs listings when you click Start.
  • Reference the documentation that was included with the hardware device so that you can find the correct process to be used to uninstall the device driver and its associated applications.
  • Contact the device manufacturer for help.
After the hardware is successfully uninstalled, install the latest version of the drivers for the hardware.

Note You can install the drivers that were included with the hardware device. However, we recommend that you visit the manufacturer’s Web site to download and install the latest version of the drivers for your hardware.

Properties

Article ID: 973649 - Last Review: September 17, 2009 - Revision: 1.1
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbexpertisebeginner kbtshoot kbsurveynew kbprb KB973649

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