Контроллер домена под управлением Windows Server 2003 может неправильно возвращать код состояния «NO_SUCH_USER (0xc0000064)» в ответ на запросы входа в систему после выключения или перезагрузки контроллера домена

Переводы статьи Переводы статьи
Код статьи: 973667 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Windows Server 2003, на контроллеры неправильно может возвращать код состояния «NO_SUCH_USER (0xc0000064)» в ответ на запросы входа в систему, после возвращается код состояния "STATUS_INVALID_SERVER_STATE (0xc00000dc)" или код состояния «STATUS_NO_MEMORY (0xc0000017)». Это происходит, когда проверяющий подлинность контроллер домена выключения или перезагрузки.

Одно из следующих компьютеров могут возвращаться код состояния:
  • Компьютер домена, с которого поступил запрос на вход в систему
  • Сервер приложений
  • Контроллер домена, пересылать запрос на вход контроллеру домена, выполняющем проверку подлинности с помощью сквозной проверкой подлинности
Неправильный код может вызвать приложение, в котором был создан запрос на вход с ошибкой или время ожидания.

Примечание.Эта проблема может возникнуть, даже если было установлено исправление 942636.
942636Windows Server 2003, на контроллеры может неправильно возвращать код состояния "NO_SUCH_USER (0xc0000064)" в ответ на запросы на вход

Причина

Данная проблема возникает, если эта служба управляет возвращаемое состояние неправильно.

Решение

To resolve this problem, you must apply this hotfix on the Windows Server 2003-based domain controllers. After you apply this hotfix, the domain controllers return the “STATUS_NO_MEMORY (0xc0000017)” status code during the shutdown process. When the client receives this status code, the client tries to contact another domain controller.

Примечание.: Windows Server 2003-based domain members must have the client side hotfix 942636 applied, see KB942636Windows Server 2003-based domain controllers may incorrectly return the "NO_SUCH_USER (0xc0000064)" status code in response to logon requests.

Сведения об исправлении

Вам доступно исправление от корпорации Майкрософт.. Это исправление предназначено для устранения проблемы, описанной в этой статье.. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема.. Исправление может проходить дополнительное тестирование.. Таким образом эта проблема не является постоянной для вас, мы рекомендуем дождаться следующего автоматического обновления программного обеспечения, содержащего это исправление..

Если исправление доступно для загрузки, имеется раздел «Доступные загрузки» в верхней части этой статьи базы знаний.. Если этот раздел не отображается, обратитесь в Службу поддержки клиентов Microsoft для получения исправления..

Примечание.Другие проблемы или если требуется устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются вами дополнительно.. Полный список телефонов поддержки и обслуживания клиентов Microsoft или информацию по созданию отдельного запроса на обслуживание вы можете найти на веб-сайте Майкрософт::
http://support.microsoft.com/contactus/?ws=support
Примечание.В форме "Исправление доступно для загрузки" отображаются языки, для которых доступно исправление. Если язык не отображается, это значит, что исправление не доступно для данного языка..

Предвартельные требования

Для установки исправления компьютер необходимо запустить Windows Server 2003 с пакетом обновления 2 (SP2).

Необходимость перезагрузки

После установки исправления компьютер необходимо перезагрузить..

Сведения о заменяемых исправлениях

Это исправление не заменяет любые другие исправления.

СВЕДЕНИЯ О ФАЙЛАХ

Английская версия исправления содержит версии файлов, приведенные в следующей таблице (или более поздние).. Дата и время для файлов указаны во всеобщем скоординированном времени (UTC).. При просмотре сведений о файле, время изменяется на местное.. Чтобы узнать разницу между временем по Гринвичу и местным временем,Часовой поясна вкладкеДата и времяэлемент панели управления.
Все поддерживаемые 32-разрядные (x86) версии Windows Server 2003 с пакетом обновления 2 (SP2)
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформаПакет обновлений
Ksecdd.sys5.2.3790.4616135,16806-Ноя-2009 г.11: 04X86SP2.
Msv1_0.dll5.2.3790.4616146,94411 Ноября 2009 г.10: 08X86SP2.
Schannel.dll5.2.3790.4530151,04016 Июня 2009 г.07: 21X86SP2.
Для всех поддерживаемых 64-разрядных версий Windows Server 2003 с пакетом обновления 2
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформаПакет обновленийНаправление поддержки
Ksecdd.sys5.2.3790.4616190,97612 Ноября 2009 г.00: 25X64SP2.Неприменимо
Msv1_0.dll5.2.3790.4616265,21612 Ноября 2009 г.00: 25X64SP2.Неприменимо
Schannel.dll5.2.3790.4530259,07212 Ноября 2009 г.00: 26X64SP2.Неприменимо
Wmsv1_0.dll5.2.3790.4616146,94412 Ноября 2009 г.00: 26X86SP2.WOW
Wschannel.dll5.2.3790.4530151,04012 Ноября 2009 г.00: 26X86SP2.WOW
Для всех поддерживаемых версий Windows Server 2003 SP2 на базе процессоров Itanium
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформаПакет обновленийНаправление поддержки
Ksecdd.sys5.2.3790.4616322,04812 Ноября 2009 г.00: 20IA-64SP2.Неприменимо
Msv1_0.dll5.2.3790.4616396,80012 Ноября 2009 г.00: 20IA-64SP2.Неприменимо
Schannel.dll5.2.3790.4530474,62412 Ноября 2009 г.00: 20IA-64SP2.Неприменимо
Wmsv1_0.dll5.2.3790.4616146,94412 Ноября 2009 г.00: 21X86SP2.WOW
Wschannel.dll5.2.3790.4530151,04012 Ноября 2009 г.00: 21X86SP2.WOW

Временное решение

To work around this problem, manually stop the Net Logon service before you shut down the domain controller.

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Майкрософт, перечисленных в разделе «Применяется к»..

Дополнительная информация

How this problem affects applications

When the "NO_SUCH_USER" status code is received, domain member computers and domain controllers do not establish a new security channel to another domain controller that is running correctly. Therefore, the logon requests that are sent by users or by applications may time out. The application that originated the logon requests may time out or may fail unless the application has failover logic or retry logic.

Включена проверка подлинности в Microsoft Internet Security and Acceleration (ISA) Server, для фильтрации сетевого трафика. Также включена проверка подлинности в службах IIS для проверки подлинности для доступа к веб-узла. Когда контроллер домена завершает работу, пользователям может быть запрещен доступ к прокси-сервера или веб-узла.

Кроме того эта проблема препятствует правильной работе Microsoft BizTalk Server. Службы BizTalk неожиданно завершить работу каждый раз при перезагрузке контроллера домена. Необходимо вручную перезапустить службы BizTalk.

В этом случае в журнал приложений на сервере, на котором размещен BizTalk Server регистрируются следующие сообщения об ошибках.

Событие с кодом 6913

Тип события: ошибка
Источник события: BizTalk Server 2006
Категория события: BizTalk Server 2006
КОД события: 6913
Пользователь: н/Д
имя_компьютера:<computer name=""></computer>
Описание: Попытка подключения к<sql server="" name=""></sql>База данных SQL Server на сервере<server name=""></server>Ошибка: «Ошибка входа пользователя (null). Причина: Не связаны с помощью доверенного соединения SQL Server. ".
Событие с кодом 5410

Тип события: ошибка
Источник события: BizTalk Server 2006
КОД события: 5410
Пользователь: н/Д
имя_компьютера:<computer name=""></computer>
Описание: Ошибка, необходимо завершить работу службы BizTalk. Ниже перечислены наиболее распространенные причины.
1) Неожиданный выход ошибки памяти. -или-
2) Невозможность подключения или потери подключения к одному из базы данных BizTalk. Служба отключается и выполнять автоматическую перезагрузку в 1 минуте. Если проблемный база данных остается недоступной, этот цикл будет повторяться.

Сообщение об ошибке: Ошибка входа пользователя (null). Причина: Не связанные с помощью доверенного соединения SQL Server.
Источник ошибки: BizTalk
Имя узла ::<server name=""></server>
служба_Windows:<service name=""></service>
Чтобы избежать возникновения этой ситуации, можно использовать сценарий диспетчера управления службами для запуска служб BizTalk, если службы будут остановлены.

Отладочная информация

Если включено ведение журнала для службы сетевого входа в систему, код состояния для входа в систему запрос регистрируется в следующем файле:
%systemroot%\Debug\Netlogon.log
Код ошибки 0xC0000064 регистрируются в файле Netlogon.log на следующих компьютерах.
  • Компьютер, который был создан запрос на вход
  • Контроллер домена, который ответил на запрос на вход
  • Приложения сервера или контроллера домена, которая перенаправляет запросы к контроллеру домена, выполняющем проверку подлинности
Примечание.Код состояния "NO_SUCH_USER (0xC0000064)" является допустимым кодом возврата, если учетная запись пользователя для проверки подлинности не существует. Эта ситуация может возникнуть, если одно из следующих условий:
  • Учетная запись пользователя не было реплицировано в домен, проверкой подлинности.
  • Учетная запись пользователя была удалена из службы каталогов Active Directory.
  • Учетная запись пользователя в запросе проверки подлинности имеет неверный формат пользователем или приложением.
Когда контроллер домена отвечает на запрос на вход, полученных с помощью сквозной проверкой подлинности, файле Netlogon.log на контроллере домена регистрирует информацию, подобную следующей:
MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Entered 
MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Returns 0xC0000064 
When the authenticating domain controller responds to a logon request that is received directly from a domain member computer in the same domain, the Netlogon.log file on the domain controller logs information that resembles the following:
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Entered 
MM/DD HH:MM:SS [CRITICAL] NlPrintRpcDebug: Couldn't get EEInfo for I_NetLogonSamLogonEx: 1761 (may be legitimate for 0xc0000064) 
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Returns 0xC0000064 
Для получения дополнительных сведений обратитесь к следующей статье Базы Знаний Майкрософт::
109626Ведение журнала отладки для службы Net Logon
Для получения дополнительных сведений обратитесь к следующей статье Базы Знаний Майкрософт::
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 973667 - Последний отзыв: 30 ноября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Ключевые слова: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbHotfixServer kbmt KB973667 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:973667

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com