V pracovní skupině, která obsahuje počítače se systémem Windows Server 2003 SP2 se nezdaří replikace mezi ADAM databáze a Active Directory Lightweight Directory Services (AD LDS)

Překlady článku Překlady článku
ID článku: 973678 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • Máte dva počítače v prostředí pracovní skupiny. Jeden z počítačů se systémem Windows Server 2003 Service Pack (SP2). Ostatní počítače se systémem Windows Server 2008 nebo Windows Server 2008 R2.
  • V počítači se systémem Windows Server 2003 SP2 nainstalujete režimu aplikace Active Directory (ADAM).
  • Instalaci služby Active Directory Lightweight Directory Services (AD LDS) v počítači se systémem Windows Server 2008 nebo Windows Server 2008 R2.
  • Při pokusu replikaci mezi ADAM databáze a databáze služby AD LDS.
V tomto případě dojde k selhání procesu replikace. Do protokolu událostí ADAM jednoho počítače je dále zaznamenána událost podobná následující:

Název protokolu: (ADAM)instance)
Zdroj: [ADAMinstance] Replikace
Datum: datum
ID události: 1084
Kategorie úkolů: replikace
Úroveň: Chyba
Klíčová slova: klasická
Uživatele: ANONYMNÍ přihlášení
Počítač: Název_počítače
Popis:
Vnitřní událost: Služba Active Directory Lightweight Directory Services nelze aktualizovat následující objekt změnami přijat adresářové služby následující zdroje. Je to proto, že během provádění změn Active Directory Lightweight Directory Services v adresářové službě došlo k chybě.

Objekt:
objekt
Identifikátor GUID objektu:
identifikátor GUID objektu
Zdroj adresářové služby:
zdroj

Synchronizace služby directory s adresářovou službou zdroj blokována, dokud je opraven problém s aktualizací.

Tato operace budou použity opět při dalším naplánované replikace.

Akce uživatele
Restartování místního počítače, pokud se tato podmínka týkající se nedostatku systémových prostředků (například nízké fyzické nebo virtuální paměti).

Další Data
Chybová hodnota:
2148074288 Zadaná data nelze dešifrovat.

Příčina

V prostředí pracovní skupiny, ADAM a ADLDS pomocí protokolu NTLM pro ověřování a zabezpečení dat serveru exchange. Nastaví NTLM relace mezi ADAM v systémech Windows Server 2003 a ADLDS v systému Windows Server 2008 nebo Windows Server 2008 R2 a výměny NTLM (veřejný klíč) klíče relace pro tuto relaci. Tento klíč se obvykle používá k šifrování a dešifrování dat a je uložen v NTLM.

V počítačích se systémem Windows Server 2003 vrátí NTLM ADAM žádný klíč. Proto výchozího klíče slouží k šifrování dat. U počítačů se systémem Windows Server 2008 nebo Windows Server 2008 R2 NTLM vrátí ADLS klíče relace. Proto je klíč relace slouží k šifrování dat. Kontrolní součet nemusí souhlasit dochází, protože používají různé klíče. To způsobí selhání replikace, která je popsána v části "Příznaky".

Řešení

Chcete-li tento problém vyřešit, nainstalujte opravu hotfix v příslušném počítači se systémem Windows Server 2003 SP2. Po použití opravy hotfix, musí přidat hodnotu registru na serveru Windows Server 2003 povolit replikaci z každé instanci služby ADAM odpovídající instanci služby AD LDS v systému Windows Server 2008 a Windows Server 2008 R2:

Podklíč REG = "HKLM\System\CurrentControlSet\Services\<adam_instance_name>\Parameters"</adam_instance_name>
Hodnota registru = NTLMSessionKey
Typ = DWORD
Hodnota = 0x1

Hodnota registru musí být na základě jednotlivé instance.


Poznámka:Po instalaci opravy hotfix a hodnota registru nastavena na 0x1, se nezdaří replikace následující:
  • Replikace mezi ADAM v systému Windows XP a patched ADAM v systémech Windows Server 2003.
  • Replikace mezi patched ADAM v systémech Windows Server 2003 a systém ADAM v systémech Windows Server 2003.

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k problému popsaného v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musíte používat systém Windows Server 2003 SP2.Další informace o možnostech získání aktualizace Windows Server 2003 service pack nebo aktualizaci Windows XP Professional x 64 Edition service pack získáte článku znalostní báze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci service pack pro systém Windows Server 2003

Požadavek na restartování

Není nutné restartovat počítač po instalaci této opravy hotfix.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné dříve vydané opravy hotfix.

Informace o souboru

Angličtina (Spojené státy) verze této opravy hotfix nainstaluje soubory, které mají atributy, které jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny podle místního času společně podle aktuálního letní čas (DST). Navíc data a časy mohou změnit při provádění některých operací se soubory.
Poznámky k informacím o soubor systému Windows Server 2003
  • Kromě souborů uvedených v těchto tabulkách, tato oprava hotfix také nainstaluje soubor katalogu zabezpečení (KBčísloCAT), je podepsaný digitálním podpisem společnosti Microsoft.
Pro všechny podporované-verze x 86 systému Windows Server 2003
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPVětev
Adamdsa.dll1.1.3790.47141,633,79224. Května-201006: 02x 86AKTUALIZACE SP2SP2QFE
Ksecdd.sys5.2.3790.4530135,16815. Června-200917: 07x 86AKTUALIZACE SP2SP2QFE
Msv1_0.dll5.2.3790.4714146,94424. Května-201006: 02x 86AKTUALIZACE SP2SP2QFE
Schannel.dll5.2.3790.4530151,04016. Června-200907: 21x 86AKTUALIZACE SP2SP2QFE
Pro všechny podporované 64bitové verze systému Windows Server 2003 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPVětev
Adamdsa.dll1.1.3790.47142,961,92024. Května-201009: 54x 64AKTUALIZACE SP2SP2QFE
Ksecdd.sys5.2.3790.4530190 97624. Května-201009: 55x 64AKTUALIZACE SP2SP2QFE
Msv1_0.dll5.2.3790.4714265,21624. Května-201009: 55x 64AKTUALIZACE SP2SP2QFE
Schannel.dll5.2.3790.4530259,07224. Května-201009: 56x 64AKTUALIZACE SP2SP2QFE
Wmsv1_0.dll5.2.3790.4714146,94424. Května-201009: 56x 86AKTUALIZACE SP2WOW
Wschannel.dll5.2.3790.4530151,04024. Května-201009: 56x 86AKTUALIZACE SP2WOW
Pro všechny podporované verze IA-64 systému Windows Server 2003
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPVětev
Ksecdd.sys5.2.3790.4530322,04824. Května-201009: 55IA-64AKTUALIZACE SP2SP2QFE
Msv1_0.dll5.2.3790.4714396,80024. Května-201009: 55IA-64AKTUALIZACE SP2SP2QFE
Schannel.dll5.2.3790.4530474,62424. Května-201009: 56IA-64AKTUALIZACE SP2SP2QFE
Wmsv1_0.dll5.2.3790.4714146,94424. Května-201009: 56x 86AKTUALIZACE SP2WOW
Wschannel.dll5.2.3790.4530151,04024. Května-201009: 56x 86AKTUALIZACE SP2WOW

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o ADAM naleznete na následujícím webu společnosti Microsoft:
ADAM koncepty
Další informace o službě Active Directory naleznete na následujícím webu společnosti Microsoft:
Obecné informace o službě Active Directory
Další informace o ochraně dat v systému Windows naleznete na následujícím webu společnosti Microsoft:
Obecné informace o ochraně dat v systému Windows
Další informace o terminologii aktualizace softwaru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 973678 - Poslední aktualizace: 24. května 2011 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003 Service Pack 2 na těchto platformách
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbqfe kbautohotfix kbhotfixserver kbexpertiseadvanced kbfix kbsurveynew kbmt KB973678 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:973678

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com