Cómo identificar datos no repetidos en distintas columnas de Excel 2007

Seleccione idioma Seleccione idioma
Cerrar Cerrar
Id. de artículo: 973741 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo
Contraer esta tablaAmpliar esta tabla
Contraer esta imagenAmpliar esta imagen
public/es/sbs/973741/sbs small.png
Este es un artículo "Paso a Paso".

Resumen

Hay ocasiones en que puede ser de interés saber qué datos no están repetidos en, por ejemplo, dos columnas u hojas distintas de datos de Excel 2007. En este artículo se explicará cómo identificar estos datos mediante una fórmula.

Introducción

Supongamos que tenemos dos columnas con datos, en hojas diferentes, como las que se muestran a continuación:

Contraer esta imagenAmpliar esta imagen
PUBLIC/es/sbs/973741/973741 01.png


Podemos ver que hay datos que no se repiten en la otra columna:

Contraer esta imagenAmpliar esta imagen
PUBLIC/es/sbs/973741/973741 02.png


En este caso se trata de un conjunto reducido de datos, por lo que podemos identificar los datos no repetidos fácilmente. Sin embargo, si se tratara de muchos más datos, tendríamos que utilizar una fórmula para que nos simplifique la tarea.

Cómo identificar datos no repetidos en dos conjuntos de valores de Excel 2007

En este caso, utilizaremos el ejemplo que propusimos en la introducción. Para detectar datos no repetidos en dos conjuntos de valores de Excel 2007, sigue estos pasos:
  1. Selecciona los datos de la primera columna y haz clic en el menú Fórmulas.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 03.png


  2. Haz clic en Asignar nombre a un rango.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 04.png


  3. Escribe un nombre para el conjunto de datos seleccionado (en este caso ?Conjunto1?) y haz clic en Aceptar.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 05.png


  4. Asigna el nombre ?Conjunto2? al otro conjunto de datos. Para ello, repite los pasos del 1 al 3 con el segundo conjunto de datos.
  5. Veremos qué datos de ?Conjunto2? no están repetidos en ?Conjunto1?. Para ello, selecciona la celda que se encuentra a la derecha del primer valor de ?Conjunto2? y escribe la fórmula =SI(ESNOD(BUSCARV( en la barra de fórmulas.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 06.png


  6. A continuación, selecciona la celda con el dato que deseas buscar, en este caso A1 (la primera de ?Conjunto2?).

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 07.png


  7. Escribe un punto y coma (;), luego Conjunto1 (donde ?Conjunto1? indica el rango de datos en el que deseas buscar datos repetidos).

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 08.png


  8. Escribe un punto y coma ";" seguido de el número de columna del rango de datos en el que se buscarán los valores repetidos, en este caso "1". Luego escribe otro punto y coma ";" y selecciona Falso ("Falso" indica que la coincidencia debe ser exacta).

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 09.png


  9. Para terminar la fórmula, escribe ));?Nuevo?;? ?). Esto significa que la fórmula mostrará la palabra ?Nuevo? si no encuentra el valor en la columna indicada, en este caso la primera de ?Conjunto1?; de lo contrario, no se mostrará nada.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 10.png


  10. La fórmula completa debe verse así:
    =SI(ESNOD(BUSCARV(A1;Conjunto1;1;Falso));?Nuevo?;? ?). Desliza la fórmula hacia abajo hasta el último valor de ?Conjunto2? para aplicarla a todo el conjunto de datos.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 11.png


  11. Ahora veremos la palabra ?Nuevo? junto a cada uno de los datos de ?Conjunto2? que no está repetido en ?Conjunto1?.

    Contraer esta imagenAmpliar esta imagen
    PUBLIC/es/sbs/973741/973741 12.png


  12. Para ver qué datos de ?Conjunto1? no aparecen en "Conjunto2?, repite los pasos del 5 al 10. Para ello, escribe la fórmula en la celda contigua al primer dato de "Conjunto1? y reemplaza en la fórmula ?Conjunto1? por ?Conjunto2?. La fórmula quedaría así:
    =SI(ESNOD(BUSCARV(A1;Conjunto2;1;Falso));?Nuevo?;? ?).


    Tu opinión nos interesa: no dudes en enviarnos tu opinión acerca de estos artículos mediante el campo de comentarios que se encuentra en la parte inferior. De esta manera, podrás mejorar su contenido. ¡Muchas gracias!

Propiedades

Id. de artículo: 973741 - Última revisión: miércoles, 05 de octubre de 2011 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Office Excel 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Basic 2007
  • Microsoft Office Professional Plus 2007
Palabras clave: 
kbhowto kbinfo kbstepbystep KB973741

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com