Sicherheit-Konfigurationsinformationen, wie z. B. die ACL wird nicht kopiert, wenn ein Sicherungs-Operator verwendet das Robocopy.exe-Dienstprogramm zusammen mit der Option/b, um eine Datei auf einem Computer zu kopieren, auf dem Windows Vista oder Windows Server 2008 ausgeführt wird

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Sie können ein Benutzerkonto hinzufügen, der Gruppe Sicherungs-Operatoren in einer Domäne.
  • Verwenden Sie dieses Konto an einem Computer anmelden, auf dem Windows Vista oder Windows Server 2008 ausgeführt wird.
  • Einige Dateien kopieren, Sie Berechtigungen oder den Besitz keinen, verwenden Sie den Robocopy -Befehl zusammen mit der Option/b .
In diesem Szenario werden diese Dateien erfolgreich kopiert. Jedoch ist deren Sicherheit Konfigurationsinformationen, z. B. eine Zugriffssteuerungsliste (ACL) für eine Datei nicht kopiert. Die ACLs der kopierten Dateien werden von den Zielordner geerbt.

Darüber hinaus gibt das Robocopy.exe -Dienstprogramm folgende Fehlermeldung:
Fehler 5 (0 x 00000005) ist NTFS-Sicherheit kopieren, um Zieldatei <xxx> Zugriff wurde verweigert.
Hinweis: Ein Mitglied der Gruppe Sicherungsoperatoren kann Datei Sicherheit Konfigurationsinformationen im backup-Modus des Dienstprogramms Robocopy.exe zugreifen. Der Member sollte sein, auf diese Informationen zugreifen, auch wenn der Member nicht Berechtigungen oder den Besitz der Datei verfügt.

Ursache

Das Dienstprogramm " Robocopy.exe " wird nicht diese Dateien geöffnet, das Flag "Sicherung Absicht" mit, wenn die Option/b verwendet wird. Dieses Verhalten verhindert den Zugriff auf Sicherheit Konfigurationsinformationen für einen Benutzer, "Sichern von Dateien und Verzeichnissen" hat (SE_BACKUP_PRIVILEGE)-Berechtigung.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, muss Ihr Computer eines der folgenden Betriebssysteme ausgeführt werden:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Informationen zur Registrierung

Sie müssen eine Änderung an der Registrierung vornehmen.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Für alle unterstützten x 86-basierten Versionen von Windows Vista und Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Robocopy.exe5.1.10.102789,08817-Jul-200912: 02X 86
Robocopy.exe5.1.10.102789,08817-Jul-200911: 46X 86
Für alle unterstützten x 64-basierten Versionen von Windows Vista und Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Robocopy.exe5.1.10.1027113,66417-Jul-200912: 21X 64
Robocopy.exe5.1.10.1027113,66417-Jul-200911: 53X 64
Für alle unterstützten Itanium-basierte Versionen von Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Robocopy.exe5.1.10.1027238,08017-Jul-200912: 08IA-64
Robocopy.exe5.1.10.1027238,08017-Jul-200911: 44IA-64

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen über die Robocopy -Befehl die folgenden Microsoft-Website:
http://technet.microsoft.com/en-us/library/cc733145.aspx
Weitere Informationen zu einem anderen Problem mit dem Befehl Robocopy finden Sie im folgenden Artikel der Microsoft Knowledge Base:
950790Fehlermeldung, wenn Sie den Robocopy-Befehl zusammen mit der /ZB-Option, verwenden Daten von einem Dateiserver mit einem Windows Vista oder Windows Server 2008-basierten Client zu kopieren: "Fehler 5: Zugriff verweigert"
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 973776 - Geändert am: Freitag, 14. August 2009 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB973776 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 973776
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