As informações de configuração de segurança, como a ACL, não são copiadas se um operador de backup usa o utilitário Robocopy.exe juntamente com a opção /B para copiar um arquivo em um computador que esteja executando o Windows Vista ou Windows Server 2008

Traduções deste artigo Traduções deste artigo
ID do artigo: 973776 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • Você pode adicionar uma conta de usuário ao grupo Operadores em um domínio.
  • Você usa essa conta para fazer logon em um computador que esteja executando o Windows Vista ou Windows Server 2008.
  • Você usar o comando Robocopy juntamente com a opção /B para copiar alguns arquivos para o qual você não tem permissões ou posse.
Nesse cenário, esses arquivos são copiados com êxito. No entanto, suas informações de configuração de segurança, como uma lista de controle de acesso (ACL), para um arquivo não são copiadas. As ACLs dos arquivos copiados são herdadas da pasta de destino.

Além disso, o utilitário Robocopy.exe retorna a seguinte mensagem de erro:
Erro 5 (0 x 00000005) copiando segurança NTFS para arquivo de destino <xxx> acesso negada.
Observação Um membro do grupo operadores pode acessar arquivo informações de configuração de segurança no modo de backup do utilitário Robocopy.exe. O membro deve ser capaz de acessar essas informações mesmo se o membro não tiver permissões ou posse de para o arquivo.

Causa

O utilitário Robocopy.exe não abre esses arquivos usando o sinalizador "tentativa de backup" quando a opção /B é usada. Esse comportamento impede o acesso às informações de configuração de segurança para um usuário que tenha o "fazer backup de arquivos e pastas" privilégio (SE_BACKUP_PRIVILEGE).

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando um dos seguintes sistemas operacionais:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações do registro

Não é necessário fazer qualquer alteração no registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para todas as versões com base em 86 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Robocopy.exe5.1.10.102789.08817-Jul-200912: 02x 86
Robocopy.exe5.1.10.102789.08817-Jul-200911: 46x 86
Para todas as versões com base em 64 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Robocopy.exe5.1.10.1027113,66417-Jul-200912: 21x 64
Robocopy.exe5.1.10.1027113,66417-Jul-200911: 53x 64
Para todas as versões baseadas em Itanium do Windows Server 2008
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Robocopy.exe5.1.10.1027238.08017-Jul-200912: 08IA-64
Robocopy.exe5.1.10.1027238.08017-Jul-200911: 44IA-64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre o comando Robocopy , visite o seguinte site:
http://technet.microsoft.com/en-us/library/cc733145.aspx
Para obter mais informações sobre outro problema com o comando Robocopy, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
950790Mensagem de erro ao usar o comando Robocopy juntamente com a opção /ZB para copiar dados de um servidor de arquivos para um cliente baseado no Windows Vista ou com base em Windows Server 2008: "Erro 5: acesso negado"
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 973776 - Última revisão: sexta-feira, 14 de agosto de 2009 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB973776 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 973776

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com