You cannot install Exchange Server 2007 Service Pack 2 on a Windows Small Business Server 2008-based computer

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SYMPTOMS

When you try to install Microsoft Exchange Server 2007 Service Pack 2 (SP2) on a Windows Small Business Server 2008-based computer, the service pack Setup program will not start.

CAUSE

This problem occurs when you run Exchange Server 2007 SP2 Setup because the Exchange Best Practice Analyzer detects the server as Small Business Server 2008 and will not allow for the service pack to install.

RESOLUTION

Microsoft has released the Exchange Server 2007 Service Pack 2 Installation Tool for Windows Small Business Server 2008. This tool automates the installation of Exchange Server 2007 Service Pack 2 on Windows Small Business Server 2008.

For more information about this tool, click the following article number to view the article in the Microsoft Knowledge Base:
974271 Description of the Microsoft Exchange Server 2007 Service Pack 2 Installation Tool for Windows Small Business Server 2008
We recommend that you use this tool to automatically install Exchange Server 2007 Service Pack 2. If you still want to manually install Exchange Server 2007 Service Pack 2, see the "How to manually install Exchange Server 2007 Service Pack 2" section.

How to manually install Exchange Server 2007 Service Pack 2

You must first create the following E12SP2READY registry value, and then you must install Exchange Server 2007 SP2:
HKEY_LOCAL_MACHINE\Software\Microsoft\SmallBusinessServer\Exchange\E12SP2READY
Note We recommend that before you create the registry key and run Exchange Server 2007 SP2 Setup, you read this complete article to understand all the known issues that may occur after you install Exchange Server 2007 SP2. There are some manual steps that you will have to perform to install the service pack and to make sure all the services work correctly after the service pack setup is complete. Additionally, the Exchange Server 2007 SP2 installation will disable the Web services on the server. You cannot install the service pack while you are connected to the server by using remote Web workplace or the Terminal Services Gateway service. You can install it remotely while you are connected by using remote desktop or by using any other method that does not rely on the Web services.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To create the E12SP2READY registry value, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\SmallBusinessServer\Exchange
    Note If the Exchange subkey does not exist, you must create it. To do this, follow these steps:
    1. Right-click SmallBusinessServer, point to New on the Edit menu, and then click Key.
    2. Type Exchange and then press ENTER.
  3. After you select the Exchange subkey that is specified in step 2, point to New on the Edit menu, and then click DWORD Value.
  4. Type E12SP2READY, and then press ENTER.
  5. Right-click E12SP2READY, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.
After you have created the E12SP2READY registry value, you can now start the Exchange Server 2007 SP2 Setup program.

Important If Forefront Security for Exchange is installed on the server, you will receive the following error message during the Readiness check:
Setup has detected that Forefront Security for Exchange Server is running on this server and has to be disabled before Exchange Server 2007 is upgraded.
When you receive this error message, follow these steps to disable Forefront Security for Exchange:
  1. Stop the following services:
    • FSCController
    • Microsoft Exchange Information Store
    • Microsoft Exchange Transport
  2. Open an Administrator command prompt.
  3. Change to the following directory:
    C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server
  4. At the command prompt, run the following command:
    fscutility /disable
    After you run this command, you receive the following message:
    Removing dependencies...

    dependency on FSCController removed from Microsoft Information Store
    dependency on FSEIMC removed from Microsoft Exchange Transport Service
    Microsoft Exchange Transport Service Agent registration removed

    Status: Microsoft Forefront Server Security NOT Integrated.”
After the Forefront services are disabled, you can continue the Exchange Server 2007 SP2 Setup and then click Retry. Exchange Server 2007 SP2 should be installed correctly.

After the service pack setup is complete, you must enable Forefront Security for Exchange if you disabled it. To do this, follow these steps:
  1. Stop the following services:
    • Microsoft Exchange Information Store
    • Microsoft Exchange Transport
  2. Open an Administrator command prompt.
  3. Change to the following directory:
    C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server
  4. At the command prompt, run the following command:
    fscutility /enable
  5. Start the following services:
    • Microsoft Exchange Information Store
    • Microsoft Exchange Transport

Known issues that may occur after you manually install Exchange Server 2007 SP2

Exchange Server 2007 does not work

To resolve this issue, restart the computer or start the following services manually:
  • Microsoft Exchange Information Store
  • Microsoft Exchange Transport

The default Web site or the Small Business Server Web Applications site is stopped and cannot be restarted

To resolve this issue, remove the Secure Sockets Layer (SSL) settings from the default Web site. To do this, follow these steps:
  1. Open Internet Information Services (IIS) Manager.
  2. Expand the server.
  3. Expand Sites.
  4. Click Default Web Site, and then click SSL settings.
  5. Click to clear the Require SSL check box, and then click Apply.
  6. Right-click Default Web Site, and then click Edit Bindings.
  7. Select HTTPs port 443, and then click Remove.
  8. Right-click SBS Web Applications, click Manage Web Site, and then click Start.

You may be unable to browse https://sites/owa or https://sites/remote

To resolve this issue, edit the bindings for the SBS Web Applications site to select the correct certificate. This issue will occur only if the Internet Address Management Wizard has not been run. To do this, follow these steps:
  1. Open Internet Information Services (IIS) Manager.
  2. Expand the server.
  3. Expand Sites.
  4. Right-click the SBS Web Applications Web site, and then click Edit Bindings.
  5. Select HTTPs port 443, and then click Edit.
  6. Under SSL certificate, select the certificate that is named "Sites."

You may be unable to browse https://remote.contoso.com/owa or https://remote.contoso.com/remote

Note In this example, remote.contoso.com is the external domain name of your site. This issue may occur only if a third-party trusted certificate is installed on the server.

To resolve this issue, run the Fix My Network Wizard to add the trusted certificate back to the SBS Web Application site.

You may be unable to use Remote Web Workplace or the Terminal Services Gateway service to connect to the server or client desktops

To resolve this issue, install the certificate on the terminal server gateway. To do this, follow these steps:
  1. Open Terminal Services Gateway Manager.
  2. Open the properties of the server.
  3. Click the SSL Certificates tab.
  4. Click Browse Certificates, and then select the appropriate certificate.

Properties

Article ID: 973862 - Last Review: August 26, 2009 - Revision: 1.1
APPLIES TO
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbsetup kbupdateissue kbtshoot kbexpertiseinter kbsurveynew kbprb KB973862

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