Non Ŕ possibile ripristinare file di grandi dimensioni nel file system NTFS quando tutti i flussi di dati che dispongono di tipo sparse attributi vengono eliminati nella versione a 64 bit di Windows XP SP2 o in Windows Server 2003 SP2

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Sintomi

╚ possibile ripristinare i file di dati di grandi dimensioni nella finestra di un file system NTFS in un computer che esegue Windows XP 64-bit versione Service Pack 2 (SP2) o Windows Server 2003 Service Pack 2 (SP2) x, l'operazione di ripristino non riesce. Inoltre, i dati nei file di dati vengono persi. Quando si verifica questo problema, l'evento seguente viene visualizzato nel Registro di sistema:

Tipo evento: avviso
Origine evento: NTFS
Categoria evento: nessuna
ID evento: 50
Computer: < Nome Computer >
Descrizione: {Scrittura non riuscita posticipato} Impossibile salvare tutti i dati per il file. I dati sono stata interrotta. Questo errore potrebbe essere causato da un errore della connessione di hardware o di rete di computer. Provare a salvare il file altrove.
Inoltre, il seguente evento viene registrato nel registro applicazione:

ID evento: 26
Categoria: nessuno
Origine: Popup dell'applicazione
Tipo: informazioni
Computer: < nome Computer >
Messaggio: Applicazione popup: Windows - scrittura rimandata non riuscita: Impossibile salvare tutti i dati per il file < nome file > I dati Ŕ stata interrotta. Questo errore potrebbe essere causato da un errore della connessione di hardware o di rete di computer. Provare a salvare il file altrove.

Nota Questo problema si verifica quando sono vere tutte le condizioni seguenti:
  1. Vengono rimossi tutti i flussi dati di tipo sparse del file.
  2. L'attributo sparse del file non viene rimosso.
  3. Le informazioni di attributo di tipo sparse sinistra sono sufficientemente grande da superare il limite di ripristino di file system NTFS.

Cause

Questo problema si verifica perchÚ l'attributo sparse di un file rimane in un file system NTFS dopo aver eliminato tutti i flussi di dati che dispongono di un attributo sparse dal file.

NTFS supporta flussi di dati denominato aggiuntivi. Quando un flusso di dati denominato aggiuntivi che ha un attributo sparse viene aggiunto a un file, l'attributo di tipo sparse Ŕ impostato anche per il file. Tuttavia, se si rimuovono tutti i flussi di dati che dispongono di un attributo sparse dal file, l'attributo di tipo sparse per il file rimane. Pertanto, quando si esegue un processo di backup e quindi ripristinare il file, il file ripristinato viene visualizzato come file di tipo sparse. Questo comportamento si verifica anche se il file Ŕ privo di dati che i flussi con attributi di tipo sparse.

Quando si ripristina il file di tipo sparse, NTFS gestisce il file come un file frammentato. Se la dimensione del file di tipo sparse Ŕ troppo grande, le risorse di sistema non sarÓ in insufficiente per completare l'operazione di ripristino. Questo problema si verifica perchÚ l'attributo sparse di un file rimane nel file system NTFS dopo aver eliminato tutti i flussi di dati che dispongono di un attributo sparse dal file.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il computer necessario eseguire uno dei sistemi operativi seguenti:
  • Windows XP 64-bit versione Service Pack 2 (SP2) x
  • Windows Server 2003 Service Pack 2 (SP2)
Per ulteriori informazioni su come installare il service pack pi¨ recente per Windows XP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere il service pack pi¨ recente per Windows XP

Per ulteriori informazioni sull'installazione di Windows Server 2008 service pack pi¨ recente, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100Come ottenere il service pack pi¨ recente per Windows Server 2003

Istruzioni per risolvere il problema

Per risolvere il problema, attenersi alla seguente procedura:

importante Questa sezione, metodo o l'attivitÓ sono contenute procedure viene illustrato come modificare il Registro di sistema. Tuttavia, possono causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi che questa procedura con attenzione. Per maggiore protezione, Ŕ eseguire il backup del Registro di sistema prima di modificarlo. ╚ quindi possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows
  1. Scaricare e installare l'hotfix.
  2. Avviare l'editor del Registro di sistema. Per effettuare questa operazione, fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  3. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
  4. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  5. Digitare NtfsResetFileSparseAttributeOnDeletingLastSparseStream e quindi premere il tasto INVIO.
  6. Fare clic con il pulsante destro del mouse su NtfsResetFileSparseAttributeOnDeletingLastSparseStream e quindi fare clic su Modifica .
  7. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  8. Uscire dall'editor del Registro di sistema.
Nota Dopo aver installare questo pacchetto di aggiornamento rapido (hotfix) e quindi configurare la voce del Registro di sistema NtfsResetFileSparseAttributeOnDeletingLastSparseStream , Ŕ necessario riavviare il computer per attivare questo hotfix nel file system NFTS.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.

Note alle informazioni di file di Windows XP e Windows Server 2003

  • Oltre ai file elencati in queste tabelle, questo aggiornamento software consente di installare anche un file di catalogo di protezione associato (KBnumber.cat) Ŕ firmato con una firma digitale Microsoft.

Per tutte le versioni di Windows XP Service Pack 2-su 64 x

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NTFS.sys5.2.3790.45701,047,55213-08-200904: 27x 64

Per tutte le versioni di Windows Server 2003 Service Pack 2 su-86 x

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NTFS.sys5.2.3790.4570593.40812-08-200912: 57x 86

Per tutte le versioni di Windows Server 2003 Service Pack 2-su 64 x

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NTFS.sys5.2.3790.45701,047,55213-08-200904: 27x 64

Per tutte le versioni basate su Itanium di Windows Server 2003 Service Pack 2

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NTFS.sys5.2.3790.45701,894,40013-08-200904: 26IA-64

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Workaround

Per aggirare il problema, Ŕ possibile copiare i file invece di backup dei file. ╚ quindi possibile ripristinare i file utilizzando software di backup.

ProprietÓ

Identificativo articolo: 973886 - Ultima modifica: mercoledý 14 ottobre 2009 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional x64 Edition
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