U kunt grote bestanden in het NTFS-bestandssysteem niet herstellen wanneer de gegevensstromen met verspreide kenmerken in de 64-bits versie van Windows XP SP2 of Windows Server 2003 SP2 worden verwijderd

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 973886 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u grote bestanden herstellen in een NTFS-bestandssysteem op een computer met Windows XP x 64-bits versie Service Pack 2 (SP2) of Windows Server 2003 Service Pack 2 (SP2), mislukt de terugzetbewerking. Bovendien is de gegevens in de bestanden verloren. Wanneer dit probleem optreedt, wordt de volgende gebeurtenis weergegeven in het systeemlogboek:

Gebeurtenistype: waarschuwing
Bron: Ntfs
Categorie: geen
Gebeurtenis-ID: 50
Computer:<computer name=""> </computer>
Beschrijving: {Uitgestelde schrijfbewerkingen zijn mislukt} Windows kan de gegevens voor het bestand wilt opslaan. De gegevens verloren zijn gegaan. Deze fout wordt veroorzaakt door een fout in de computerhardware of netwerkverbinding. Probeer het bestand ergens anders opslaan.
Bovendien wordt de volgende gebeurtenis vastgelegd in het toepassingslogboek:

Gebeurtenis-ID: 26
Categorie: geen
Bron: Toepassingspop
Type: informatie
Machine:<computer name=""> </computer>
Bericht: Toepassingspop: Windows - Uitgestelde schrijfbewerkingen zijn mislukt: kan niet alle gegevens opslaan voor het bestand <file name=""> de gegevens verloren gegaan zijn. Deze fout wordt veroorzaakt door een fout in de computerhardware of netwerkverbinding. Probeer het bestand ergens anders opslaan. </file>

OpmerkingDit probleem treedt op wanneer alle volgende voorwaarden voldaan is:
  1. De verspreide gegevensstromen van het bestand verwijderd.
  2. Het kenmerk sparse van het bestand niet verwijderd.
  3. De informatie links kenmerk sparse is groot overschrijden terugzetten beperking van het NTFS-bestandssysteem.

Oorzaak

Dit probleem treedt op omdat het kenmerk sparse van een bestand op een NTFS-bestandssysteem blijft nadat u alle gegevensstromen hebben het kenmerk sparse uit het bestand verwijderen.

NTFS ondersteunt aanvullende benoemde gegevensstromen. Wanneer een aanvullende benoemde gegevensstroom die een kenmerk sparse is toegevoegd aan een bestand, wordt het kenmerk sparse ook instellen voor het bestand. Als u alle gegevensstromen met een kenmerk sparse uit het bestand verwijdert, blijft echter het kenmerk sparse voor het bestand. Dus wanneer u een proces voor back-up en herstel het bestand, wordt het herstelde bestand weergegeven als een verspreid bestand. Dit gebeurt zelfs als het bestand geen gegevens streams die verspreide kenmerken.

Wanneer u een verspreid bestand herstelt, verwerkt NTFS het bestand als een gefragmenteerd bestand. Als een verspreid bestand is te groot, is de systeembronnen is onvoldoende om de herstelbewerking te voltooien. Dit probleem treedt op omdat het kenmerk sparse van een bestand op het NTFS-bestandssysteem blijft nadat u alle gegevensstromen hebben het kenmerk sparse uit het bestand verwijderen.

Oplossing

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze hotfix alleen uit op systemen waarop de in dit artikel beschreven probleem zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige problemen ondervindt, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.

Als u de hotfix downloaden, is er een sectie 'Hotfix downloaden beschikbaar' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.

OpmerkingAls er nog andere problemen optreden of als er oplossingen vereist is, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking voor deze specifieke hotfix komen. Bezoek de volgende Microsoft-website voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken:
http://support.Microsoft.com/contactus/?ws=support
OpmerkingHet formulier 'Hotfix gedownload' geeft de talen waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is omdat een hotfix voor die taal beschikbaar.

Vereisten

Voor deze hotfix moet op uw computer een van de volgende besturingssystemen worden uitgevoerd:
  • Windows XP x 64-bits versie Service Pack 2 (SP2)
  • Windows Server 2003 servicepack 2 (SP2)
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het installeren van het meest recente servicepack voor Windows XP:
322389De meest recente Windows XP servicepack ophalen

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het installeren van het meest recente servicepack voor Windows Server 2008:
889100Het meest recente servicepack voor Windows Server 2003 verkrijgen

Instructies voor het oplossen van het probleem

Dit probleem als volgt:

BelangrijkDeze sectie, methode of taak bevat stappen voor het wijzigen van het register. Echter, kunnen ernstige problemen optreden als u het register onjuist bewerkt. Zorg ervoor dat u deze zorgvuldig stappen. Reservekopie van het register voordat u het wijzigen voor extra bescherming. Vervolgens kunt u het register herstellen als er een probleem optreedt. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over back-up en terugzetten van het register:
322756Back-up en terugzetten van het register in Windows
  1. Download en installeer het pakket.
  2. Start Register-Editor. Klik hiertoe opStart, klik opUitvoeren, typRegedit, en klik vervolgens opOK.
  3. Zoek en selecteer de volgende registersubsleutel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
  4. Op deBewerkenin het menuNieuwe, en klik vervolgens opDWORD-waarde.
  5. TypeNtfsResetFileSparseAttributeOnDeletingLastSparseStream, en druk vervolgens op invoeren.
  6. Klik met de rechtermuisknopNtfsResetFileSparseAttributeOnDeletingLastSparseStream, en klik vervolgens opWijzigen.
  7. In deWaardegegevensin het vak1, en klik vervolgens opOK.
  8. Sluit Register-Editor.
OpmerkingNadat u dit hotfixpakket installeert en configureert u deNtfsResetFileSparseAttributeOnDeletingLastSparseStreamregistervermelding, moet u het opnieuw inschakelen van deze hotfix op het bestandssysteem NFTS.

Bestandsgegevens

De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Het verschil tussen UTC en lokale tijd, gebruikt u deTijdzonetabblad in deDatum en tijditem in het Configuratiescherm.

Opmerkingen over bestandsinformatie in Windows XP en Windows Server 2003

  • Naast de bestanden die in deze tabellen worden vermeld, installeert deze update ook een bijbehorende-catalogusbestand (KBnumber.cat) die is ondertekend met een digitale handtekening van Microsoft.

Voor alle ondersteunde x 64 versies van Windows XP SP 2

Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
NTFS.sys5.2.3790.45701,047,55213 Aug 200904: 27x 64

Voor alle ondersteunde x 86 versies van Windows Server 2003 SP 2

Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
NTFS.sys5.2.3790.4570593,40812 Aug 200912: 57x 86

Voor alle ondersteunde x 64 versies van Windows Server 2003 SP 2

Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
NTFS.sys5.2.3790.45701,047,55213 Aug 200904: 27x 64

Voor alle ondersteunde Itanium-versies van Windows Server 2003 SP 2

Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
NTFS.sys5.2.3790.45701,894,40013 Aug 200904: 26IA-64

Status

Microsoft heeft bevestigd dat dit probleem in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op' is.

Workaround

U kunt het probleem omzeilen bestanden in plaats van de back-up bestanden kopiëren. Vervolgens kunt u de bestanden terugzetten via back-upsoftware.
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 973886 - Laatste beoordeling: zaterdag 19 maart 2011 - Wijziging: 2.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional x64 Edition
Trefwoorden: 
kbfix kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe kbmt KB973886 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:973886

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com