O serviço de Roteamento e Acesso Remoto não é iniciado quando não há conectividade de rede

Este artigo fornece uma solução para um problema em que o Serviço de Roteamento e Acesso Remoto (RRAS) não é iniciado quando não há conectividade de rede.

Aplica-se a: Windows Server 2012 R2, Windows Server 2016, Windows Server 2019, Windows 10, Windows 8.1, Windows 7, Windows Server 2008 R2
Número original do KB: 973990

Sintomas

Em um sistema Windows, o serviço de Roteamento e Acesso Remoto (RRAS – nome do serviço: RemoteAccess) não é iniciado quando não há conectividade de rede. Por exemplo, RemoteAccess não começa quando toda a conectividade de rede com fio está desconectada ou quando a conectividade sem fio é desligada.

Além disso, você não pode criar novas conexões de entrada quando não há conectividade de rede. Isso ocorre porque as conexões de entrada exigem que o RemoteAccess seja iniciado.

Motivo

Quando RemoteAccess é iniciado, ele tenta inicializar determinadas funções no IAS (Serviço de Autenticação da Internet) para autenticação. A inicialização da IAS falha quando não há conectividade de rede. Portanto, RemoteAccess não é iniciado. A falha de inicialização da IAS é por design quando não há conectividade de rede. Em seguida, você verá o comportamento mencionado na seção Sintomas .
Esse comportamento é independente da instalação do NPS (Servidor de Política de Rede), o sucessor da IAS.

Solução alternativa

Para iniciar o RemoteAccess para criar uma nova conexão de entrada, seu computador precisa estar conectado a uma rede. Depois que RemoteAccess for iniciado, você ainda poderá criar uma nova conexão de entrada depois de se desconectar da rede.

Para marcar o status de RemoteAccess, marcar o estado do serviço RemoteAccess (Roteamento e Acesso Remoto) na guia Serviços no Gerenciador de Tarefas do Windows.

Status

Este é o comportamento padrão. O serviço RemoteAccess está desabilitado nas versões do servidor Windows e do cliente por padrão.