Ağ bağlantısı olmadığında Yönlendirme ve Uzaktan Erişim hizmeti başlatılmıyor

Bu makalede, ağ bağlantısı olmadığında Yönlendirme ve Uzaktan Erişim hizmetinin (RRAS) başlatılmaması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Windows Server 2012 R2, Windows Server 2016, Windows Server 2019, Windows 10, Windows 8.1, Windows 7, Windows Server 2008 R2
Özgün KB numarası: 973990

Belirtiler

Bir Windows sisteminde, ağ bağlantısı olmadığında Yönlendirme ve Uzaktan Erişim hizmeti (RRAS - hizmet adı: RemoteAccess) başlatılmaz. Örneğin, Tüm kablolu ağ bağlantısı kesildiğinde veya kablosuz bağlantı kapatıldığında RemoteAccess başlatılmaz.

Ayrıca, ağ bağlantısı olmadığında yeni gelen bağlantılar oluşturamazsınız. Bunun nedeni gelen bağlantıların RemoteAccess'in başlatılmasını gerektirmesidir.

Neden

RemoteAccess başlatıldığında, kimlik doğrulaması için İnternet Kimlik Doğrulama Hizmeti'nde (IAS) belirli işlevleri başlatmaya çalışır. Ağ bağlantısı olmadığında IAS başlatma işlemi başarısız olur. Bu nedenle, RemoteAccess başlatılmaz. IAS başlatma hatası, ağ bağlantısı olmadığında tasarım gereğidir. Ardından Belirtiler bölümünde bahsedilen davranışı görürsünüz.
Bu davranış, IAS'nin ardılı olan Ağ İlkesi Sunucusu'nun (NPS) yüklenmesinden bağımsızdır.

Geçici Çözüm

RemoteAccess'i başlatarak yeni bir gelen bağlantı oluşturmak için bilgisayarınızın bir ağa bağlı olması gerekir. RemoteAccess başlatıldıktan sonra ağ bağlantısını kestikten sonra da yeni bir gelen bağlantı oluşturabilirsiniz.

RemoteAccess'in durumunu denetlemek için Windows Görev Yöneticisi'ndeki Hizmetler sekmesinin altında RemoteAccess hizmetinin (Yönlendirme ve Uzaktan Erişim) durumunu denetleyin.

Durum

Bu davranış tasarımdan kaynaklanır. RemoteAccess hizmeti, Windows sunucusu ve istemci sürümlerinde varsayılan olarak devre dışıdır.