"Windows cannot install required files" error when installing a third party storage driver during Windows setup

Article translations Article translations
Close Close
Article ID: 974038 - View products that this article applies to.
Expand all | Collapse all
Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptom



Consider the following scenario:
  • You start Windows setup by booting using DVD media.
  • The DVD drive is attached to a storage controller which is supported natively by the drivers supplied with Windows. However, you wish to install third-party drivers for this controller.
  • During Windows Setup, on the page titled "Where do you want to install Windows?", you choose "Load Driver" to install the third party storage driver. You install a new driver for the storage controller which your DVD drive is attached to.


In this scenario, you may encounter the following error message after starting Windows Setup:

Windows cannot install required files. Make sure all files required for installation are available, and restart the installation.

Cause



This behavior may occur when you are installing from DVD media, and you load a new driver for the storage controller that the DVD drive is attached to.

This behavior occurs because after installing the new driver, it is possible that the drive letter for the DVD drive may change. If the drive letter changes, Windows is no longer able to find the disc in order to continue with setup.

Resolution

To work around this problem, do not install the third party storage driver during Windows Setup. Instead, run Windows setup using the drivers provided with Windows. After Windows Setup completes, you may install the third party storage driver using Device Manager.

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

Properties

Article ID: 974038 - Last Review: July 24, 2009 - Revision: 1.0
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbrapidpub kbnomt KB974038

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com