Responses that are scheduled by the Operations Manager agent may not run at the specified time

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Article ID: 974098 - View products that this article applies to.
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Symptoms

In Microsoft System Center Operations Manager, rules can be authored to run a script on a timed basis. The rule can be further authored to synchronize at a specific time each day. However, even when you configure a rule to do this, the script may not run at the exact time that is specified in the dialog box. Instead, there may be a small delay. The delay may be anywhere from several seconds to several minutes, depending on how busy the target Health service is and the interval length between scheduled runs.

Cause

This is expected behavior because the scheduler module was designed to minimize the resource effect on the agent and was not intended for real-time accuracy. Even if the Health service agent is heavily taxed, any delays in running the response should be no more than one percent of the time since the last scheduled run.

Resolution

If you want to run an agent response with more accuracy, you can use either of the following methods:
  • If the response is a script, the Windows Task Scheduler service can be used to run the script at an exact time. Task Scheduler is a service that uses a completely different timing mechanism.
  • If the response is not a script, or the script cannot be run under Task Scheduler, a rule can be authored to run the response when a custom event is observed on the agent. The Windows Task Scheduler can be used to programmatically create an event in the agent’s local event log on a scheduled basis. The Operations Manager agent would run the response every time that the Task Scheduler adds this custom event to the event log.
System Center Orchestrator may also be used to schedule various things refer to the technet libary for System Center Orchestrator on scheduling for more information here: 

http://technet.microsoft.com/en-us/library/hh225044.aspx

Properties

Article ID: 974098 - Last Review: August 14, 2012 - Revision: 1.1
Applies to
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center 2012 Operations Manager
  • Microsoft System Center Operations Manager 2007 R2
  • Microsoft System Center Operations Manager 2007 Service Pack 1
Keywords: 
kbtshoot kbexpertiseinter kbsurveynew kbprb KB974098

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