FIX: The Host Print Service (Snaprint.exe) may stop unexpectedly when you print jobs with transparent sections in Microsoft Host Integration Server

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Article ID: 974406 - View products that this article applies to.
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SYMPTOMS

In a Microsoft Host Integration Server 2006 or Microsoft Host Integration Server 2009 environment, the Host Print service (Snaprint.exe) may stop unexpectedly. Additionally, the following event will be logged in the system event log:

Event ID: 7034
Source: Service Control Manager
Message: The SNAPrint service terminated unexpectedly. It has done this %1 time(s).

Notes
  • When you work in a Host Integration Server 2006 or Host Integration Server 2009 64-bit environment, the Host Print service stops unexpectedly.
  • When you work in a Host Integration Server 2006 or Host Integration Server 2009 32-bit environment, the Host Print service does not stop. However, the print job does not finish.

CAUSE

This issue occurs because the Snaprint.exe process crashes when the system tries to log transparent data to the event log to indicate that the data will not be printed.

RESOLUTION

Service pack information for Host Integration Server 2006

To resolve this problem, obtain the latest service pack for Host Integration Server 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Host Integration Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For x86-based version of Host Integration Server 2006
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File nameFile versionFile sizeDateTimePlatform
winvprt.dll7.0.2935.0206,67221-Aug-200910:06x86

For x64-based version of Host Integration Server 2006
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File nameFile versionFile sizeDateTimePlatform
winvprt.dll7.0.2935.0252,22421-Aug-200910:08x64

For x86-based version of Host Integration Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winvprt.dll8.0.3719.2208,70409-Sep-200919:41x86

For x64-based version of Host Integration Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Winvprt.dll8.0.3719.2247,12009-Sep-200919:43x64Not Applicable
Winvprt.dll8.0.3719.2208,70409-Sep-200919:41x86SYSWOW

WORKAROUND

In the properties of the Print Service in SNA Manager, select the No Event Log for skipping transparent section option. This disables the logging and enables the print jobs to continue.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 974406 - Last Review: October 7, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Host Integration Server 2009
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe KB974406

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