REVISIÓN: El servicio de impresión de host (Snaprint.exe) puede dejar de responder inesperadamente cuando imprime trabajos con secciones transparentes en Microsoft Host Integration Server

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Id. de artículo: 974406 - Ver los productos a los que se aplica este artículo
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Síntomas

En un entorno Microsoft Host Integration Server 2006 o Microsoft Host Integration Server 2009, el servicio de Host Print (Snaprint.exe) puede dejar inesperadamente. Además, se registrará el suceso siguiente en el registro de sucesos del sistema:

ID. de suceso: 7034
Origen: Administrador de control de servicios
Mensaje: El servicio SNAPrint terminó inesperadamente. Lo ha hecho este %1 veces.

Notas
  • Cuando se trabaja en un entorno de Host Integration Server 2006 o Host Integration Server 2009 64-bit, el servicio de Host Print se detiene inesperadamente.
  • Cuando se trabaja en un entorno de Host Integration Server 2006 o Host Integration Server 2009 32 bits, no se detiene el servicio de Host Print. Sin embargo, no finaliza el trabajo de impresión.

Causa

Este problema se produce porque el proceso Snaprint.exe se bloquea cuando el sistema intenta iniciar sesión de datos transparente en el registro de sucesos para indicar que no se imprimirán los datos.

Solución

Información del Service pack para Host Integration Server 2006

Para resolver este problema, obtenga el service pack más reciente para Host Integration Server 2006. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
979497Cómo obtener el service pack más reciente de Host Integration Server 2006

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de atención al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener instalado para aplicar esta revisión de Host Integration Server 2006.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento fecha y hora en el panel de control.
Para x 86 versión de bits de Host Integration Server 2006
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
winvprt.dll7.0.2935.0206,67221-Ago-200910: 06x 86

Para x versión de 64 bits de Host Integration Server 2006
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
winvprt.dll7.0.2935.0252,22421-Ago-200910: 08x 64

Para x 86 versión de bits de Host Integration Server 2009
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Winvprt.dll8.0.3719.2208,70409-Sep-200919: 41x 86

Para x versión de 64 bits de Host Integration Server 2009
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaTipo de servicio
Winvprt.dll8.0.3719.2247,12009-Sep-200919: 43x 64No aplicable
Winvprt.dll8.0.3719.2208,70409-Sep-200919: 41x 86SYSWOW

Solución

En las propiedades del servicio de impresión en SNA Manager, seleccione el registro de sucesos no se omitirá la sección transparente opción. Esto deshabilita el registro y permite continuar los trabajos de impresión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 974406 - Última revisión: jueves, 04 de febrero de 2010 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Host Integration Server 2009
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbhotfixserver KB974406 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 974406

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